Results 1 to 8 of 8
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Lewes, East Sussex, Sussex, United Kingdom
    Posts
    232
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Report preview error (A97 SR2)

    I have a bizarre problem when I preview a report. One text box, which is right-aligned, & has the Controlsource : =Format([date_invoice],"dd mmm yyyy"), appears left-aligned on Print Preview, and is perfectly right aligned on the hardcopy print.

    There is no code on the report which references this control.

    Has anybody come across this before ? If so, did they find a solution ?

    Thanks for your help

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report preview error (A97 SR2)

    No idea, really, but what are the following properties for the offending text box?
    - Font size
    - Height
    - Can Grow
    - Can Shrink

  3. #3
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Lewes, East Sussex, Sussex, United Kingdom
    Posts
    232
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report preview error (A97 SR2)

    Hans

    Font = AGaramond 10, CanGrow = No, canShrink = No, Height = 0.476cm, width = 2.383cm. Nothing at all unusual, as far as I can see. There are plenty of other similar text boxes on the report which preview correctly. I have deleted & re-created the box a couple of times, with no change.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report preview error (A97 SR2)

    I agree there is nothing unusual there. I asked because of a Knowledge Base article mentioning that text boxes on a report could display incorrectly in some settings, but yours isn't among them.

    What happens if you create a new report based on the same data, and create a right-aligned text box with control source =Format([date_invoice],"dd mmm yyyy") on it?

  5. #5
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Lewes, East Sussex, Sussex, United Kingdom
    Posts
    232
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report preview error (A97 SR2)

    Hans

    I duplicated the control twice on the same report above the problem control & it's fine. The only thing I can see that might cause a problem is that it is the second control on the line. I have attached a zipped bmp file which shows the problem control highlighted in orange

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report preview error (A97 SR2)

    I'm afraid that your picture, however interesting, doesn't give me a clue to what is happening. If you wish, you can post a stripped down version of the database. See <post#=412737>post 412737</post#> for instructions.

  7. #7
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Lewes, East Sussex, Sussex, United Kingdom
    Posts
    232
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Report preview error (A97 SR2)

    Hans

    I managed - somehow - to solve this by duplicating the control several times. I then deleted the original & replaced it with one of the copies. On the third attempt it worked OK & the control now shows correctly on Print Preview. Why it works now & didn't then is beyond my knowledge.

    Anyway, thanks for your help

    Bodders

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report preview error (A97 SR2)

    Glad you were able to solve it. We'll probably never know what caused the problem...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •