Results 1 to 10 of 10
  1. #1
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    XP Boot.INI problem (XP Service Pack 2)

    I've just built a new PC, and when I came to install Windows, I don't recall any problems (I used a brand new XP Home disk which I was quite surproised to see from my local PC supplier, already had SP2 included.)

    Each time I start however, I get the screen-full of text informing me that there is a problem, and offering me last good, safe mode etc.

    If I open Boot.ini, I get the following (see attached jpg

    When I click on Check all Boot paths, I get the normal second screen & when I click yes, the screen disappears, but If I run Msconfig again, nothing has changed.

    Any suggestions please.

    Thanks

    Colin

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    Is there any more detail that there is a problem?

    Joe
    Joe

  3. #3
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    I've never encountered the "signature(xxxxx)" that I see in your BOOT.INI file. Perhaps this is causing the problem? Try backing up your current BOOT.INI and editing out that portion, leaving everything else intact, and see if you still encounter an error message.
    -Mark

  4. #4
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    No

    Other than every start has to go through the safe/last known good routine.

    Of course I might not notice an other issue, but it seems to be OK otherwise.


    Colin

  5. #5
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    The "signature" bit appears in two place. I'm not sure which to delete.

    Here's the full text

    [boot loader]
    timeout=30
    default=signature(de75de75)disk(1)rdisk(0)partitio n(1)WINDOWS
    [operating systems]
    signature(de75de75)disk(1)rdisk(0)partition(1)WIND OWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect


    I'm also a bit nervous about booting up if I hit a problem, and my "new" boot.ini file isn't recognised.

    I've created a new floppy Boot Disk
    using this.

    [boot loader]
    timeout=30
    Default= multi(0)disk(0)rdisk(0)partition(1)windows

    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)windows="Window s XP"


    But if the problem is SP2 based, I'm worried that it might not work
    I'm going to try booting from this new floppy before I edit the Boot.ini on the C drive.

    Colin

  6. #6
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    The floppy would not boot.

    Luckily, the system found the info it needed on c: and continued


    Any suggestions


    COlin

  7. #7
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    Delete both. Try this instead:
    <pre>[boot loader]
    timeout=30
    default=disk(1)rdisk(0)partition(1)WINDOWS
    [operating systems]
    disk(1)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect</pre>

    Make sure that you mark the file read-only, system, and hidden after editing it.
    -Mark

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    I would leave the Signature bit of Boot.Ini alone, unless you know it is causing a problem. Have a look at the explanation in <!mskb=227704>Microsoft Knowledge Base Article 227704<!/mskb>

    StuartR

  9. #9
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: XP Boot.INI problem (XP Service Pack 2)

    1. Propbably you use two devices with "cable select" settings on the same controller, that's why the entry is signature(x) instead of multi(x) or scsi(x).
    2. To start Windows, it is strongly recommended to use /fastdetect switch in [operating systems]
    3. Try to change the switch to /NoExecute=OptOut and see what's happen.

  10. #10
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Edinburgh, Midlothian, Scotland
    Posts
    492
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: XP Boot.INI problem (XP Service Pack 2)

    I managed to correct it by using the new boot.ini details and changing from cable select.

    Many thanks to everyone


    Colin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •