Results 1 to 4 of 4
  1. #1
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    AutoPlay, Labels, Icons, and Autorun.inf (XP Pro (Sp1))

    Help! [img]/forums/images/smilies/sad.gif[/img] WinXP has decided to modify "AutoPlay" in several different ways. Most of them are for the better -- really. However, it now does NOT recognize the "Label" or "Icon" values in the Autorun.inf files!

    I have created multiple discs with Autorun.inf files, and none of them seem to have the Label or Icon values processed. This is apparently a known behavior:
    <A target="_blank" HREF="http://autorun.moonvalley.com/instructions.htm#label">
    "Note: labels do not function correctly on Windows XP systems. The label does not show up and neither will the icon. If you expect your CD to be used on Windows XP computers you may not want to specify a label."</A>

    It is known, but certainly not well-defined -- or even mentioned -- on the Microsoft pages.

    (More Detailed Information from Microsoft - still ignoring the fact that label and icon are ignored).
    ________________

    Now, for SOME reason my Sonic Record Now program is able to create a label for my CD -- but it does NOT use the Autorun.inf file to do it. HOW DOES IT WORK??

    Next, I can get a different icon, but ONLY if I use an executable in the Open value. The Open value in Autorun.inf seems to work perfectly well, and the icon (assumed icon 0) is directly extracted without error, but the Icon value in Autorun.inf is ignored. Is there another way to get an icon to display??

    Thanks.

  2. #2
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoPlay, Labels, Icons, and Autorun.inf (XP Pro (Sp1))

    *Follow up (for anyone interested): WinXP apparently has a bug. If a "Label" value is specified in the Autorun.inf file, then the "Icon" value is ignored. So... removing the "Label" value fixed the Icon issue! (I had wanted to use that for 'backward compatibility', but I guess that is out the window...)

    If you don't specify a Label you can specify an Icon. Obviously, I will have to be satisfied with Record Now making the label! Thanks for listening! ;-]

  3. #3
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoPlay, Labels, Icons, and Autorun.inf (XP P

    Nothing like the steady march of "progress," hey? <img src=/S/grin.gif border=0 alt=grin width=15 height=15> Thanks for sharing that bit of info.
    -Mark

  4. #4
    Silver Lounger
    Join Date
    Jan 2001
    Location
    Long Beach, California, USA
    Posts
    1,912
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: AutoPlay, Labels, Icons, and Autorun.inf (XP P

    I just wish Microsoft had placed that little tidbit of data on their web site. Would have saved me hours of time... [img]/forums/images/smilies/sad.gif[/img]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •