Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Cannot retain read-only property

    Windows 98SE. I have ONE folder which will not retain its read-only property through a re-boot.
    I've written a batch file to set it on start-up, only to find that Explorer re-sets it when opened. I can then set if from within Explorer, then it stays set for the session.
    Any clues what may be going on here - other folders I want set to be read-only happily retain this property and I can't work out why this one is different.

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Cannot retain read-only property

    Is this a main folder or a sub folder?

    If a sub, it may be being changed because a upper level folder is checked to apply to sub folders and is NOT read only..

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    Hi Dave:
    This is a new one on me. I have Win 98 SE & can't find a setting to have parent folders apply to child folders.

  4. #4
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Cannot retain read-only property

    It has been a long time since I worked on a 98 machine.

    This option pops up on the XP machines when one selects apply, just thought that it may be the issue.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  5. #5
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Re: Cannot retain read-only property

    THe one I cannot change (permanently) is on the root of C: and the ones I can change are sub-folders to the one I can't change. Does this make a difference (and if so how can I get round it) ?

    Thanks for the help

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    Hi Martin:
    I'm not sure why it's not retaining it's read-only attribute. Is it a system folder? What folder is it?

  7. #7
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Re: Cannot retain read-only property

    It is just a folder in the root of C: where I keep my own files - documents, music, spreadsheets etc. I want the read-only property set so I can change its icon.

  8. #8
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    Can you create a new (empty) folder on your C: drive and change the icon to what you want? If so, you could try renaming the original folder, rename the new folder to the name of the old folder, and then move the contents to the new folder. There may be something within the original folder that is stopping Windows from making it read-only.

  9. #9
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Re: Cannot retain read-only property

    Thank you ! We are getting closer.

    I have, as you suggested, created a new folder, put all the files into it and renamed it like the old one. The read-only property is now retained.
    That leaves me with the old folder, now renamed. When I try and delete the old folder I get a dialog which says "<folder> is your documents folder. It cannot be deleted. If you wish to delete this folder, first choose another folder to be your documents folder."

    Explorer help says "right click on My Documents and change its target". But when I do that there is no "target" option. This isn't a big deal as I have buried the empty folder somewhere it doesn't show but I am curious how to tie up this loose end.

    I think it was this designation as my "documents folder" which was preventing the folder staying read-only.

    Thanks though for setting me down the right path albeit not quite 100% finished !

  10. #10
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    5,016
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    Probably the easiest way of addressing this is to install and run TweakUI (for Windows 98) and use the Special Folders Location on the My Computer tab to nominate a folder of your choice. Its location is significant, because this is where many applications will Open/ Save to, by default.

    Alan

  11. #11
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Re: Cannot retain read-only property

    Done with TweakUI - my thanks to all.

    Final question in this thread then - does anyone know how to make a shortcut AT THE DRIVES LEVEL in Explorer to a folder (in C: as it happens). I used to have one, deleted it and foolishly cannot remember how I created it ! I don't mean a desktop shortcut (I can do that) or a shortcut to a file (I can do that too !).

    The point is that it is visible when the left pane view is compressed.

  12. #12
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    5,016
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    I'm not quite sure of what you mean here. All I can envisage is a shortcut under "My Computer" to the desired folder. This will be visible even when all drive contents are "compressed" down to just drive letters. Is this what you're after?

    Alan

  13. #13
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts

    Re: Cannot retain read-only property

    Yes - exactly so. How do I put a shortcut at this particular location ?

  14. #14
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    5,016
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    I appear to have jumped the gun on this. I thought it was straightforward (was probably thinking of the Desktop). I can't see any obvious way of doing so, but this registry hack will allow the creation of a new "special" folder. A shortcut may not be possible though.

    Alan

  15. #15
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cannot retain read-only property

    Can you not map the folder to appear as a drive? I'm not too sure if you can do this with W98 - you may need to use the SUBST command.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •