Results 1 to 9 of 9
  1. #1
    4 Star Lounger
    Join Date
    Sep 2002
    Location
    Stafford, Staffordshire, England
    Posts
    585
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Startup Window Problem (XP)

    I have used the startup option to display a switchboard form to show when a database is opened by the user. This works fine but for one slightly irritating problem. Before it decides on dispalying the switchboard, it seems to scroll through a number of windows before showing the one I want. It looks a little unsightly. I hope I've explained my problem sufficiently.

    Thanks in advance.
    <font color=blue><font face="Script MT Bold"><big>Rob</big></font face=script></font color=blue>

  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    Did your switchboard form open other forms ?
    If so try to open them hidden :
    DoCmd.OpenForm "FormName", , , , , acHidden
    Francois

  3. #3
    4 Star Lounger
    Join Date
    Sep 2002
    Location
    Stafford, Staffordshire, England
    Posts
    585
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    The display changes quickly but I think the switchboard window maximises, minimises then maximises again. No other forms are opened. The on open event is set to maximise.
    <font color=blue><font face="Script MT Bold"><big>Rob</big></font face=script></font color=blue>

  4. #4
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    Can you post a stripped version of your db so we can see what happens?
    Francois

  5. #5
    4 Star Lounger
    Join Date
    Sep 2002
    Location
    Stafford, Staffordshire, England
    Posts
    585
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    Thanks for the responses, Francois. I'm unable to strip it down. I've tried to create a blank db and import only the switchboard but I get errors when trying to open it. It seems to be looking for the underlying items. I'll keep on trying.
    <font color=blue><font face="Script MT Bold"><big>Rob</big></font face=script></font color=blue>

  6. #6
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    If you want, you can send it to my e-mail address (see my profile)
    Francois

  7. #7
    4 Star Lounger
    Join Date
    Sep 2002
    Location
    Stafford, Staffordshire, England
    Posts
    585
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    Thanks, Francois. I've emailed the db.
    <font color=blue><font face="Script MT Bold"><big>Rob</big></font face=script></font color=blue>

  8. #8
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    In the macro Autoexec, remove the line Minimize. This is not needed as the database is not displayed due to you startup options.
    In fact, you can delete the Autoexec macro, the switchboard form will be opened also by startup options.
    Did this solve the problem ?
    Francois

  9. #9
    4 Star Lounger
    Join Date
    Sep 2002
    Location
    Stafford, Staffordshire, England
    Posts
    585
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Startup Window Problem (XP)

    Francois,

    You've nailed it. Thanks for your time and expertise. I'll log this for future reference.
    <font color=blue><font face="Script MT Bold"><big>Rob</big></font face=script></font color=blue>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •