Results 1 to 6 of 6
  1. #1
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Crosstab query fields don't show in report wizard (2002)

    Hi,

    I am trying to create a report using the wizard and a crosstab query. The problem is the fields in the query do not populate in the wizard. I then tried to build the report from scratch (the fields do show in the field list) but that was a disaster. Any ideas as to why the info doesn't show? I have other crosstab queries that the data shows on.

    Thanks,
    Leesha

  2. #2
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Crosstab query fields don't show in report wizard (2002)

    In the crosstab query, the headings (or field names) are created on the fly.
    Beside of NewReferral and off_name your query will have headings from 1 to 12 depending of the dates selected in the form.
    In the report, you have to write code to set the record source of the textboxe(s) to the corresponding fields.
    Do you need to have more than one month on the report and if yes, how many ?
    Francois

  3. #3
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Crosstab query fields don't show in report wizard (2002)

    Hi,

    I need to have the report show all 12 months, even if there is not data for the month. It will be a progressive kind've thing on a monthly basis. If the employee wants to look at a year that is complete, then it would show all 12 months. If they are looking for instance at 2004 it would at this point only show 10 months with 11 and 12 being empty. I would be having a totals at the bottom for total Newreferrals overall.

    I don't understand how this is keeping the wizard from showing the fields. Other crosstabs that I've done reports from show the fields but this one doesn't. Is there something about the query that is prohibiting it?

    Leesha

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Crosstab query fields don't show in report wizard (2002)

    Your crosstab fields will show up in the wizard if you have set up column headings for each of the twelve months. Then even though the data is missing for a month, Access will be able to recognize the field.
    Charlotte

  5. #5
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Crosstab query fields don't show in report wizard (2002)

    Like in one of or previous post, open the query in design view, open the property window and in the column headings, enter :
    1,2,3,4,5,6,7,8,9,10,11,12
    This will give you the 12 months in the query. Now you'll be able to use the wizard to create the report as you have a fixed number of columns
    Francois

  6. #6
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Crosstab query fields don't show in report wizard (2002)

    <img src=/S/blush.gif border=0 alt=blush width=15 height=15>
    I guess I didn't realize that I had to create the column headers in a crosstab to be able to show them in a report. I thought it was an optional step.

    Thanks Francois and Charlotte too!

    Leesha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •