Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    May 2001
    Location
    Columbia MD USA
    Posts
    107
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Autofit to Content - lame? (2002)

    Hi all,

    I'm in a situation where using the Tables | Autofit | Autofit to Contents would solve some problems I'm having. However, using AutoFit to Contents is creating it's own set of problems. It's forcing some very nasty wraps in my table, something like:

    Constitutio
    n

    Aside from explicitly setting the column width, is there a way to force Word not to wrap a word in a table when Autofit is active? I can't use non-breaking spaces to solve this, because there is only one word in the cell in question. :-(

    Any advice would be greatly appreciated.

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autofit to Content - lame? (2002)

    Hi Arianna:
    I've noticed the same thing from time to time (Word 2000). I'm not sure what order Word uses to adjust the column widths, but it can happen that widening one column will cause problems in another. Nevertheless, what I find is more accurate is to select the entire table, position the cursor over one of the column borders, & double click. It does seem to be a bug to me.

    CORRECTION: I just noticed something. It happens in normal view, but not in Print Preview or Print Layout. It is merely a display problem. If you go to Tools/Options/View tab & uncheck "Wrap to window", it should appear correctly!

  3. #3
    2 Star Lounger
    Join Date
    May 2001
    Location
    Columbia MD USA
    Posts
    107
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Re: Autofit to Content - lame? (2002)

    Hi Phil, thanks a bunch for your suggestions

    The "select table & double click" trick worked well for 4 of my problematic tables, but one of them refused to play.

    On my system, Tools/Options/View tab & uncheck "Wrap to window" is already off, and the bad word wrap is not affected by being in Normal vs Print Layout view. However, this got me to thinking, (which is dangerous) so I went to Tools/Options/Compatibility and disabled "Use Printer Metrics to lay out document". With that change, the bad wraps have appeared to evaporate!

    I'll post a follow up if this turns out to be a only temporary reprieve.

    Now I have to decide which is more annoying: those surprise! page breaks one can get when "use print metrics" is disabled, or those nasty word wraps. <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>

    That double-click trick is slick. (hey, that's a rhyme!) How did you ever figure that one out?

    Thanks again,
    Arianna

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Autofit to Content - lame? (2002)

    The "double-click" trick also works in Excel and in Windows Explorer (in Details view) to make columns fit to contents.

  5. #5
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Autofit to Content - lame? (2002)

    Alt-Click doesn't seem to select a column for me. In Word 2003 SP1 it seems to open the Research task pane - how useless <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>

    StuartR

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autofit to Content - lame? (2002)

    Hi Arianna:
    The Printer metrics option made no difference for me (Word 2000), nor did other options I tried. Well, whatever works.

    I don't remember where I learned the double click method, but there are a few mouse tricks that I've picked up over the years. Alt+Click will select a column (easier than holding the mouse on top of the column in just the right spot until it turns into a thick arrow down) & Alt+Double Click will select the entire table, even if the cursor is outside the table.
    Cheers,

  7. #7
    4 Star Lounger
    Join Date
    Dec 2003
    Location
    Zoetermeer, Zuid-Holland, Netherlands
    Posts
    559
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autofit to Content - lame? (2002)

    <hr>The Printer metrics option made no difference for me (Word 2000)<hr>
    When ticked, this causes repagination of the document if it's opened by someone with another printer then the author used when creating the document. So changing this has no effect on the documents you created yourself, unless you specify another printer.
    This repagination also takes place if the document is "printed" to a Doc2Pdf convertor, often causing the resulting PDF to look different from the original Word document. For this reason we have (programmatically) unchecked the printer metrics option throughout our organisation.

  8. #8
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autofit to Content - lame? (2002)

    > select the entire table, position the cursor over one of the column borders, & double click.

    Wow!! A very nice trick.

    It even works to autofit one or more columns, or even cells, leaving the unselected cells unchanged.
    And it doesn't change the table to "AutoFit to content" in the future, which slows down Word and usually isn't what you want anyway.

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>Klaus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •