Results 1 to 10 of 10
  1. #1
    2 Star Lounger
    Join Date
    Jun 2004
    Location
    L, Schleswig-Holstein, Germany
    Posts
    184
    Thanks
    0
    Thanked 0 Times in 0 Posts

    No linked tables in the manager??! (2003)

    Hi everyone!

    See attached screenshot for further explanation. I just divided my database into frontend and backend and everything worked fine. But now when moving the backend around on my harddrive and trying to use the Linked Table Manager to reallocate the linked tables to the new location, I just can't see any tables in the manager!
    How to get those tables back into the manager? (I still do have the database as a whole, it's just that I want to split the database and then teach the users how to use the linked table manager)

    Yours
    Dennis

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: No linked tables in the manager??! (2003)

    Do you have multiple versions of Access on your machine? There are some reports in the newsgroups that this can cause the problem you have.

    Try the following:
    <UL><LI>Quit Access.
    <LI>Check the installation path for Office 2003. The default is C:Program FilesMicrosoft OfficeOffice11.
    <LI>Select Start | Run...
    <LI>Type

    regsvr32.exe "C:Program FilesMicrosoft OfficeOffice11accwiz.dll"

    (substituting the correct path if necessary) and press Enter.[/list]Does the linked table manager work correctly now?

  3. #3
    2 Star Lounger
    Join Date
    Jun 2004
    Location
    L, Schleswig-Holstein, Germany
    Posts
    184
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No linked tables in the manager??! (2003)

    Yeah I do have the runtime version of Access 2000 on my machine too, but I hope THAT version doesn't get destroyed if I run that command? THe runtime version is very important for another program which doesn't work with Access 2003 (love those incotible programs)

    Dennis

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: No linked tables in the manager??! (2003)

    That shouldn't have any effect on the runtime version; AccWiz.dll contains the functionality of (some of) the wizards in Access; those aren't available in runtime Access anyway.

  5. #5
    2 Star Lounger
    Join Date
    Jun 2004
    Location
    L, Schleswig-Holstein, Germany
    Posts
    184
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No linked tables in the manager??! (2003)

    Did what you told me to do and the AccWiz got reinitialized, but still the same problem. No linked tables in the manager but linked tables existing.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: No linked tables in the manager??! (2003)

    Read BUG: List of currently linked tables may not appear in Linked Table Manager Wizard in a database in Access 2003 to make sure that you have done it correctly.

    If that doesn't help either, you might check the Windows Registry. The standard dire warnings about editing the registry apply.
    Type regedit in the Start | Run... box to open the Registry Editor.
    Locate the HKEY_CLASSES_ROOTTypeLib{5B87B6F0-17C8-11D0-AD41-00A0C90DC8D9}8.00win32 key.
    The (Default) value should be the path and filename of the AccWiz.dll for Access 2003.
    The same holds for HKEY_CLASSES_ROOTTypeLib{5B87B6F0-17C8-11D0-AD41-00A0C90DC8D9}8.10win32.
    If necessary, correct the entries.

  7. #7
    2 Star Lounger
    Join Date
    Jun 2004
    Location
    L, Schleswig-Holstein, Germany
    Posts
    184
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No linked tables in the manager??! (2003)

    You're the best helper!

    Yeah that helped, the 8.0 entry in the registry was wrong. It's good to know that sometimes even Microsoft provides a solution for a problem [img]/forums/images/smilies/wink.gif[/img]

    Thanks
    Dennis

  8. #8
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Richland, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No linked tables in the manager??! (2003)

    Hans,

    You da man! If you got 5

  9. #9
    4 Star Lounger
    Join Date
    Aug 2003
    Location
    Stroud, United Kingdom
    Posts
    548
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: No linked tables in the manager??! (2003)

    Hi

    Just wanted to say TOP POST!! Sorted me out too. Those registry values .... <img src=/S/doh.gif border=0 alt=doh width=15 height=15>

    I wonder if my Reg value was pointing to the wrong ACCWIZ.dll due to me joining a workgroup recently and then rejoining the System one.

    anyhow Cheers Hans!!
    Thanks,

    pmatz

  10. #10
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: No linked tables in the manager??! (2003)

    I don't think joining a workgroup would change the reference to AccWiz. I fear it's hard to say what exactly causes this kind of problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •