Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Exchange outgoing mail settings (Office 2003 / Server 2003 SB)

    Hello All,
    I have a small problem that I hope someone out there knows how to fix.....

    I have a small server group setup here. It consists of four PCs connected to one server running MS Server 2003. I have exchange configured and running. I can send mails between the internal PCs without problems. I cannot send mail to the internet though. I need to configure exchange to send the mail through my ISP's SMTP server. How can I make it so that all outgoing mail messages are routed to this other server address?

    Thanks,
    Mark

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    I'm going to move this to the Servers Forum as, strictly speaking, that is where it belongs. Hopefully you'll get a quick response from there....

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,592
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: Exchange outgoing mail settings (Office 2003 / Server 2003 SB)

    I'd recommend going to Microsoft Exchange Server 2003 support site. There's a link about setup on the left. There are links to lots of other documentation there also.

    Joe
    Joe

  4. #4
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Thanks for the pointer. I have tried several ways listed in the help documentation but none of it seems to work. When I use OE to send mail and set the SMTP address to the ISP mail server, it works no problem. For instance, I and sending mail through yahoo and using the pop mail server pop.mail.yahoo.com and my ISP's smtp address of mail.bellsouth.net. This works without problems. How can I make exchange just forward all outgoing mail to the mail.bellsouth.net address? I have tried setting up a SMTP connector but that produces a message that says relaying is not allowed, use bellsouth.net.

    Thanks,
    Mark Santos

  5. #5
    Lounger
    Join Date
    Sep 2004
    Location
    Evesham, Worcestershire, England
    Posts
    28
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    You can get this problem if your e-mail address domain is not hosted by the ISP. If exchange is set up to use you domain.local address or another provider is hosting your company domain (e.g. mycompany.com), bellsouth.net will see you e-mail address as foreign and assume you are relaying. I'd suggest:

    1. Check that Exchange is set up correctly with you external domain name (not a .local address)
    2. If another company is hosting your domain name, you should be able to route outgoing SMTP traffic to their mailservers rather than bellsouth's.
    3. Another option would be to transfer the domain to bellsouth (however you will also need to transfer any web pages which could a problem).
    4. Last option, set Exchange to send e-mail directly (don't relay through the ISP).

  6. #6
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Vienna, Wien, Austria
    Posts
    5,009
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    One last word: be VERY careful if you set up relaying on your own Exchange Server. Make sure that you have some form of validation for the addresses being relayed. Otherwise, you will find - before very long - that some spammer's empire 'bots will have identified your Exchange Server's IP address and will be using it for relaying of their own "products" (in wholesale quantities). HTH
    Gre

  7. #7
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Thanks for the pointers. Today, I have figured out how to get the server to receive mail. Now I just need to get it to send mail and I will be all set. Do you have any idea how to make exchange send the mail directly? Do I need an SMTP connector to send mail?

    Thanks,
    Mark

  8. #8
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Thanks, yeah that is something I need to look into to make sure things are as locked down as possible. Where do you suggest I look to make these settings? Also, if you have any pointers per my previous post, I would appreciate it.

    Thanks,
    Mark

  9. #9
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Vienna, Wien, Austria
    Posts
    5,009
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    In Microsoft Exchange 2003 Server Manager, right-click on the SMTP Service icon and choose Properties. There should be a tab on the dialog named Relaying. You are advised to choose a criterion for allowing addresses to use relaying. In your case, it should be [username]@[yourdomain].com HTH
    Gre

  10. #10
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Thanks again,
    I can't seem to locate the item you are talking about. When I open the exchange server manager (2003), I see the servers and connectors which have something to do with the SMTP stuff. In either one of those areas, I see a check box for allowing relaying but nothing like what you are mentioning. Is there something else I am missing?

    Thanks,
    Mark

  11. #11
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Vienna, Wien, Austria
    Posts
    5,009
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Unfortunately, my copy of Server Manager is on another machine. Under the check box, however, is there not a large, empty dialog box with an Add command button underneath that (to the left). The Add button should allow you to enter exceptions. HTH
    Gre

  12. #12
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    I will have to look for that. What should the exception be listed as? Beyond that, here is what I have for settings:

    Server Protocols - SMTP / Default SMTP Virtual Server. This is set for the internal IP of the machine. There is no forwarding designated here.
    Connectors - Internet Mail SMTP Connector. I have a standard setup here, but I have tried forwarding all mail to another mail server as well. Under the address space tab, I have "allow messages to be relayed...." checked.

    What does the setting of the default SMTP server need to be set to? (the outside IP address??)

    Thanks,
    Mark

  13. #13
    Platinum Lounger
    Join Date
    Nov 2001
    Location
    Vienna, Wien, Austria
    Posts
    5,009
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    >Internet Mail SMTP Connector. I have a standard setup here, but I have tried forwarding all mail to another mail server as well. Under the address space tab, I have "allow messages to be relayed...." checked.

    Pardon my <img src=/w3timages/censored.gif alt=censored border=0> previous description. <img src=/S/grovel.gif border=0 alt=grovel width=31 height=23> The Internet Mail SMTP Connector is what I was attempting to describe. This is what needs to be locked down. Without applying any filters, checking the checkbox is what creates open season for spammers through your Exchange Server. The creation of filters should be in the dialog box underneath the checkbox - as described in my previous post.

    The SMTP server IP address should be (one of) your own.
    Gre

  14. #14
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Indianapolis, Indiana, USA
    Posts
    527
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    Thanks,
    I finally got the ISP to open port 25 for me. I am still having issues sending mail to the internet though. I have tried setting the server to send mail directly but it will not go. I have also tried having the mail go to the ISP's outgoing mail server and that returns a reply of relaying is not allowed. Maybe my problem is that I do not have my DSL modem set up correctly. My configuration is as follows:

    1. Connection comes in from outside and hits the modem
    2. Modem is set for static IP
    3. I have enabled the modem to pass through the IP address to the server
    4. The server outside (dirty) ethernet card has the static ip address.

    Do I need to configure the my server to use the DNS servers that show up on the modem configuration screen? I also see an ip gateway address that has a different subnet then the static ip address of the modem. What does this mean? Should the default gateway on the server be set for the ip gateway address that the modem sees?

    Thanks and Merry Christmas!

    Mark

  15. #15
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Exchange outgoing mail settings (Office 2003 /

    The packet reaching your ISP SMTP server needs to have an IP address that was given to you by the ISP. I don't know if the error messages show you what address it thinks you have but that would be the first thing. If messages are exiting your network with some address outside the range your ISP gave you, which would be rather mysterious, then there must be something wrong with your (presumably static) IP address on your SBS box, or it is being replaced by some other device on the way to the modem. If you visit a site like BrowserHawk from your SBS box -- scroll down to IPAddr -- does it tell you anything unexpected? (Obviously your network might treat SMTP and web traffic differently, but it's worth a check.)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •