Results 1 to 5 of 5
  1. #1
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Slow-opening Reports (2000)

    I've had this happen before, but then it stopped for awhile. All of a sudden, reports are taking a long time to open, even in design mode. This time I've noticed that there is alot of network activity when I open the report, which is odd since both the frontend and backend are local. However, my default printer is on another PC, and this appears to be the culprit. When a local printer is set as the default, the reports open virtually instantaneously in design mode.

    So, anyone know why this is? And is there a cure?
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  2. #2
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Slow-opening Reports (2000)

    Can you set your default to yet another PC?

    I had a similar situation at a client's a few years back, it turned out to be a network connection to a particular set of PCs. They fixed it by swapping that lot of PCs to another line on the network. I may not have my terms correct here, but that was the gist of it.

  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Slow-opening Reports (2000)

    But why the network activity when I'm just opening a report in design mode?
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  4. #4
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts

    Re: Slow-opening Reports (2000)

    It's primarily because Access tries to retrieve the default settings for the printer so it can make sure that the report print setup parameters are compatible with the default printer. This whole area is a real pain - especially when you have to select a specific printer to print tractor-feed forms or other similar needs. It does get better in 2002/2003 however as more of the printer object is exposed in Access.
    Wendell

  5. #5
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Slow-opening Reports (2000)

    But it doesn't always act like this, which is the strange part! It seems to be in streaks. I'll go a long time with reports opening in design mode very quickly, then all of a sudden they start taking a long time.
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •