Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Jun 2004
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Index problem??? (Access 97)

    A client has today experienced a problem whereby when they called up the Database window, there were no Reports displayed although over 50 exist. Then, when the client clicked on the Tables tab, the following message was displayed:-

    Operation invalid without a current index.

    The client then tried going to the Queries and Forms tabs, but each time the following message was displayed:-

    " Isn

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 28 Times in 28 Posts

    Re: Index problem??? (Access 97)

    Although I haven't seen this particular error message, it seems that an index on one of the system tables in which information about database objects is stored, had become corrupt. Fortunately, indexes can be reconstructed from scratch; this is one of the functions of Compact and Repair database.
    It is almost impossible to find out why such corruption occurs - a network hiccup while a modified database object was being saved would be a potential culprit.

  3. #3
    Lounger
    Join Date
    Jun 2004
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Index problem??? (Access 97)

    Thanks for the advice Hans!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •