Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Some how when i reinstalled the hard drive and windows, the USB 2.0 ports on the IBM thinkpad 80% of the time are recognized by windows as usb1.0 ports and thereby the attached usb printers hard drives etc are forced to act like usb1.0 add ons.
    IBM says that this is a windows software problem and not a hardware issue.
    There is an intel patch that intermittently makes the usb ports act like 2.0 but it doesn't last.
    Any suggestions.
    I have checked the drivers and they are all like my new machine at least I think so.
    Jerome

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Have you tried removing the USB root hub and letting Windows rediscover it?

    Joe

  3. #3
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Yes I tried this and I tried it again now. Did not help the USB 2 ports are acting like usb1 ports with real slow down in efficacy
    Jerome

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Windows is up-to-date patch wise? Are you sure all the hardware is 2.0?

    Joe

  5. #5
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    yes all up to date patch wise. And yes the hardware is 2.0.
    Thanks for trying
    Jerome

  6. #6
    Bronze Lounger
    Join Date
    Apr 2001
    Location
    Peterborough, Ontario, Canada
    Posts
    1,450
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    I have a similar problem, with a twist. There are two ports on my Toshiba Satellite Pro, and when I plug a USB2 flash drive into one I get a warning that it can go faster with USB2, but not with the other. Device manager lists 4 host controllers and 4 root hubs, but only one of the controllers is listed as USB2, and why there are four when there are only two connectors beats me, although this computer has every connector in the book and they may be for an optional module. I'd better add that I haven't compared the speeds yet, but I just chanced on this thread and dived in.

  7. #7
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    When you rebuilt the hard drive did you use the System CD that came from IBM or a MS CD?

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  8. #8
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Yes exactly, but in my case both are acting like usb1. I wish there was some way of comparing the differences to see where the glitch is. But no one really seems, to know, including MSFT and IBM, as to how the usb2 ports are recognized, it is supposed to be a driver issue, but no one seems to say okay download driver xyz and install it to overwrite a usb1 driver. Just weird and a real pain. At least you have one usb that works. The difference in using them can make a backup with a usb device 9 hrs vs 1 hr.
    Jerome

  9. #9
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    I used the IBM system cd to restore. Then I had to re install all the programs which caused some problems, needed the windows xp cd which i had separately and used to have it grab some system files. IBM said that is a known problem and Intel has a patch which I have used to make the usb drivers correct. Worked originally but just won't hold.

  10. #10
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    What is this "windows cd" that you used?
    I hope you did NOT mix the use of a IBM and a MS cd, as they will have different drivers on them. If the MS cd is one of the first one that were made it will have ONLY USB 1 drivers, as USB2 was NOT out at that time.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  11. #11
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    IBM only gives computer restore cds to put it back to a new computer, cant use them to pull files from. Had a HP xp cd I bought on Ebay to use with sp1. Which may have been a mistake. But still should be way to pull the right files/ drivers to correct the problem. This cd issue is a problem with IBM no way to get new files if windows decides to suddenly want to see a windows cd. AND Besides the intel patch was supposed to correct this issue but it just doesn't all the time and mainly gives you 1 usb connect before it reverst back from 2. to 1.o
    Any way can overwrite the usb1 drivers to make it all right?
    Jerome

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Did you install XP SP-2 separately? If so, see <!mskb=873169>Microsoft Knowledge Base Article 873169<!/mskb>. If IBM says it is an Intel problem have you checked their site for a patch?

    Joe

  13. #13
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Joe
    Yes I did. I will check the article after lunch back in 1 hr.and Thanks
    Jerome

  14. #14
    5 Star Lounger
    Join Date
    Aug 2001
    Location
    NY, NY, USA
    Posts
    626
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    Briefly looked at it when it says update each driver. update the root and all the 4 subdrivers under it?

  15. #15
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts

    Re: USB2.0 ports are being shown as USB 1.0 ports by w (Windows XP SP2)

    I think the article says the updated drivers, bios, and firmware are very important. So, I'd say yes to all the drivers. I'd also check for BIOS updates for the PC and firmware updates for the devices.

    Joe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •