Results 1 to 10 of 10
  1. #1
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Switchboards and Startup (2002 SR 3)

    For some reason, when I make a switchboard, it doesn't appear in Forms, nor in the list of opttions given in the startup options box. I suspect I've got a duff switch somewhere. Can anyone help?

    best wishes

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Switchboards and Startup (2002 SR 3)

    Do you see the switchboard form in the Forms section of the database window?

  3. #3
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Switchboards and Startup (2002 SR 3)

    No--that's what's puzzling me.
    However, I've just tried opening a database elsewhere on my network that does have a functioning switchboard, and I get an 'Error opening DLL message', no 48. The code on which the VBA gets stuck is Set con = Application.CurrentProject.Connection.

    thanks

    Philip

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Switchboards and Startup (2002 SR 3)

    Do you have a Switchboard Items table in the Tables section of the database window?

  5. #5
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Switchboards and Startup (2002 SR 3)

    Yes I do--but please see also my edit to what I just posted--I think we're working simultaneously.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

  7. #7
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Switchboards and Startup (2002 SR 3)

    Not obviously. regsvr32.exe says it can't find any of the DLLs, even though they are there. I've tried installing the latest MDAC (which is 2.8), and I'm told it's incompatible with my Windows, It says
    LoadLibrary ("C:Program") failed--the specified module could not be found
    (is there something odd about c:Program?)
    I've got serious backache and am going back to bed for a bit.
    Thanks for everything.

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Switchboards and Startup (2002 SR 3)

    That sounds as if your Windows is seriously messed up. I'm afraid this is outside my scope.

    All the best with your back.

  9. #9
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Switchboards and Startup (2002 SR 3)

    There's something very odd about "C:Program". It sounds like you've got a registry problem. What Windows version are you running? If it's XP, you might try falling back to the last system restore point.
    Charlotte

  10. #10
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Switchboards and Startup (2002 SR 3)

    The problem was that I was neglecting to put the inverted commas in the regsvr32 command. All is now well--though I had to delete the existing switchboard table and start again.

    thanks to both for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •