Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Jul 2001
    Posts
    280
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Autoexec problem (Access 2000)

    I have a database that opens by an autoexec macro,this macro opens a form,excutes a function and then quits.However, at the end i get the message "cannot find the path,make sure that path and filename are correct and that all required libraries are available. I have attached the database.In order to work,you have to remove the xxxx from the autoexec name of the macro.
    How can i avoid this problem? I suspect the autoexec macro creates the problem I will be very grateful if somebody looks at my database and tells me how can i correct the action.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Autoexec problem (Access 2000)

    I assume that your real database contains more code than the one you attached. I experience no problems if I rename the macro to AutoExec and reopen the database.

  3. #3
    Gold Lounger
    Join Date
    Jun 2001
    Location
    Crystal Beach, FL, Florida, USA
    Posts
    3,436
    Thanks
    1
    Thanked 34 Times in 34 Posts

    Re: Autoexec problem (Access 2000)

    Sounds like you might have a references problem. You might want to check them to see if one is marked as "Missing".
    Mark Liquorman
    See my website for Tips & Downloads and for my Liquorman Utilities.

  4. #4
    3 Star Lounger
    Join Date
    Jul 2001
    Posts
    280
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Autoexec problem (Access 2000)

    Thank you for our reply.Will you please open my attached database.It is quite simple, you have only to rename the macro
    from autoexecxxxx to autoexec and open the database again.You will sget then the problems that i have.I have no other reference
    nort anything special that might give rise to this error..Maybe the line DoCmd.Quit is not in the right place?.Becasue i get the error
    when i am quitting the database, even though the database is all right.

    best regards

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Autoexec problem (Access 2000)

    I did rename the macro to AutoExec and reopened the database - I mentioned that in my previous reply. I get NO error message. Also, I don't see missing references, but that depends on the system, so it is a good idea to follow Mark Liquorman's suggestion to check for missing references (Tools | References... in the Visual Basic Editor).

  6. #6
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Autoexec problem (Access 2000)

    I don't get an error on opening it either. I notice that you do have a reference set to both ADO 2.1 and the Office 10 library. Is that what your references show on your machine? Since Access 2000 is part of Office 9 and Access 2002 is part of Office 10, I would suggest you check those references...
    Charlotte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •