Results 1 to 5 of 5
  1. #1
    4 Star Lounger
    Join Date
    Oct 2002
    Location
    Sayre, Pennsylvania, USA
    Posts
    504
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Print View Displays OK, but doesn't Print Parts (2000)

    Hi,
    I have a report and a subreport. The subreport lists parts. I have this same report in 2 areas, when I create a new order and when I view an existing order. When I view an exisiting order everything works great. Both reports are the same with the exception of query names and etc.

    When I create a new order, and view this order in print preview it looks fine, shows the parts and everything. When I actually print it, everything prints but the parts.
    I'm doing some more checking but any thoughts as to why something would view correct but not print?
    Thanks,
    Deb

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 28 Times in 28 Posts

    Re: Print View Displays OK, but doesn't Print Parts (2000)

    Sounds mysterious. It's hard for us to say anything about it without seeing the database, so if you can't find the cause yourself you might consider posting a stripped down version of the database.

  3. #3
    4 Star Lounger
    Join Date
    Oct 2002
    Location
    Sayre, Pennsylvania, USA
    Posts
    504
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Print View Displays OK, but doesn't Print Parts (2000)

    Ok, I'm going to try and copy a few things first. Thanks, Deb

  4. #4
    4 Star Lounger
    Join Date
    Oct 2002
    Location
    Sayre, Pennsylvania, USA
    Posts
    504
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Print View Displays OK, but doesn't Print Parts (2000)

    I found the problem, I had to switch some code around. I realized I was running code to change a flag once the user went into print preview, so when they actually printed the report, no parts were there to print because of an update query i was running.
    Thanks,
    Deb

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 28 Times in 28 Posts

    Re: Print View Displays OK, but doesn't Print Parts (2000)

    Glad you found it! <img src=/S/smile.gif border=0 alt=smile width=15 height=15>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •