Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Melbourne, Fl USA
    Posts
    123
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Report doesn't show ttl for 1st record (Access 2002 SP3)

    I created the attached db to track hrs of training for each person in our group. It has hrs from both 2004 and 2005. When I select any report - I'm prompted for a start and end date. All that works fine, but the first record isn't complete. Ex: Preview Training Report by Employee. I input 1-1-05 & 1-31-05 for the begin/end dates. Report shows 1st record, but the YTD field in the name footer that should contain total hrs summing EDS and Inhouse is blank. As you can see, all subsequent records are fine. Doesn't matter what dates I use, the first record's YTD total is always blank. Help?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Report doesn't show ttl for 1st record (Access 2002 SP3)

    This is because Text35 is null in the first record. To get around this, set the Control Source for the YTD text box to

    =Nz([Text33],0)+Nz([Text35],0)

    The Nz function replaces null values in the first argument with the value specified in the second argument.

  3. #3
    2 Star Lounger
    Join Date
    Jan 2004
    Location
    Melbourne, Fl USA
    Posts
    123
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thanks

    Makes perfect sense - thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •