Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Lewiston, Maine, USA
    Posts
    293
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Add/Remove Programs blank?

    Over the weekend, something happened to my WinME system - Add/Remove Programs from the control panel shows nada - blank.
    Also AVG Free Resident Shield stopped loading <grrrrr>..
    As far as I can tell, this started after I tried out a password wallet program but removed almost as fast as I loaded it.
    I've done a virus scan with AVG, but with the resident shield not loading I'm not sure how sound this is.
    I've tried doing a restore point from 2 weeks ago, but restore eventually quits saying that it can't restore from that point and suggests using another point.
    I've tried restoring a backup from two days before but the same symptoms appear - AVG Resident Shield stops and my Add/Remove Programs shows blank.
    I'm just about convinced that I should do a clean install.
    any ideas?

    Thanks.
    Bob

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Add/Remove Programs blank?

    If you can afford it replace the machine with a new one running XP. You will be MUCH happer. As history shows it, Me is the shorest lived OS.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,527
    Thanks
    1
    Thanked 614 Times in 550 Posts

    Re: Add/Remove Programs blank?

    What are your hardware specs? You may be able to get XP running OK with your current setup or with a modest investment.

    Joe

  4. #4
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Before you "abandon ship" as it were, have you run Spybot and/or AdAware to see if you've picked up a nasty? From what you write, it sounds like the machine is still (somewhat) operational, so I'd give them a try.

  5. #5
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Lewiston, Maine, USA
    Posts
    293
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Thanks for the suggestions Dave and Joe, but at this time a new machine is out of the question, and my present system (933 mz, 384mb ram) would support XP, but there again the cost may be prohibitive - I have an HP ScanJet 5P that runs off a SCSI card (the scsi and scanner are 'not' supported by XP). <sigh>. If my cost was only the OS I could change, but I feel I'd need to beef up my ram another 128 megs and replace my scanner.

    Bob

  6. #6
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Lewiston, Maine, USA
    Posts
    293
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Hi Al,
    I don't abandon ship easily <g>, my ME system has been running flawlessly (except for this past weekend). I've already ran Adaware and Spybot and both reported my system 'squeaky' clean. Tonight my next step will be to run scandisk and a full defrag (overnight).
    What puzzles me is that AVG resident shield has stopped functioning. And no visible way to re-activate it. (I've even tried uninstalling and reinstalling AVG to no success. And a quick scan of the AVG users forum brings up no hits.
    After my scandisk and defrag, I 'may' try to reinstall windows over itself - but that my cause more probs than I have now - eventually a clean install may be my only alternative.

  7. #7
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Sorry, that's all I can think of right now. The fact that you had said that the AV program had stopped functioning is what made me think it might be a nasty. Good luck, Bob.

  8. #8
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    Lorain, Ohio, USA
    Posts
    953
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Found this...it might/might not be what you are looking for???
    http://www.pcanswers.co.uk/tips/default.as...&subsectionid=o

  9. #9
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,527
    Thanks
    1
    Thanked 614 Times in 550 Posts

    Re: Add/Remove Programs blank?

    What SCSI card do you have? SCSI certainly is supported by XP you just need the correct driver for the card. Here's an HP article describing a workaround for the 5P HP Scanjet - Workarounds for Older HP Scanjet Scanners in Microsoft® Windows XP . If you have the slot available for memory you can find the XP Home OEM upgrade + 128 MB Memory for < $125 USD (maybe a less depending on the memory you need).

    Joe

  10. #10
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    I don't know if it's a problem for anyone else, Lonnie, but I've tried several times to check your link and all it does is go to the top level domain (pcanswers.co.uk). I even tried to copy the complete URL into the address bar, but it immediately changes to the top level URL. Does that site require subscription? Lastly, I tried to search the site for the article number (17829) and also came up empty.

  11. #11
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    Lorain, Ohio, USA
    Posts
    953
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Don't know what happened...but here's the screenshot from my google search.
    Attached Images Attached Images

  12. #12
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    Lorain, Ohio, USA
    Posts
    953
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank?

    Add/Remove Programs list gone

    And how do I get it back?


    I seem to have lost the list of programs from my Add/Remove Programs Control Panel. I think that I must have deleted them by mistake. Have you got any ideas on how to solve this problem?
    Graeme Wesley






    The list in Add/Remove Programs is held in the Registry (specifically, the HKEY_LOCAL_MACHINE SOFTWARE Microsoft Windows Current Version Uninstall key), so it appears this information is missing or lost. The easiest thing to do is restore a backup of your Registry, but how you do this depends on the version of Windows you

  13. #13
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Lewiston, Maine, USA
    Posts
    293
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank? / Fixed !! <g>

    Hi Lonnie,
    Thanks for posting that article in full, restoring my registry from a previous backup solved the case of the missing add/remove programs listing. That - my friend - was a life-saver (and not the sweet kind).
    Joe, Dave, BigAl, thanks for all the info and concepts. I will definitely keep those in mind when/if my need grows to an XP status. I just cannot see upgrading when ME does for me exactly what I need done - and this is probably only the second time I've had a problem like this.
    To recap my complete fix:
    1 - First I uninstalled AVG Free - since it wasn't running full force it was useless. I then installed Avast Home Edition (also free for home use). With Avast I performed a complete system scan and found 1 Worm-I or worm-T - tried deleting it but discovered that 'it' was lodged in my Restore Archive directory. To cure that I turned off Restore in ME, and rebooted - then turned it back on and rebooted again - that is about the only way to remove anything from the archived restore directories. And then re-ran a complete virus scan on my system - nice and squeeky clean.
    2 - With your suggestion to do a registry restore I went back two weeks to the earliest date available - voila - the add/remove listing was there.
    3 - After I had a clean system, and the add/remove list was back, I uninstalled Avast and did a clean install of the AVG Free (I still prefer that program). After updating the definition files - everything seems to be honkey dorey.

    Thanks to all - and hopefully this will help some other user sometime to recover his/her system.

    Sign me off as a happy camper.
    Bob

  14. #14
    3 Star Lounger
    Join Date
    Jun 2001
    Location
    Lewiston, Maine, USA
    Posts
    293
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Add/Remove Programs blank? / Fixed !!

    Hi Joe,
    Didn't mean to neglect your post about XP supporting SCSI cards, but I have an older Symbios Logic 53C416 Adapeter (for HP Scanjets) and the last time I checked that version was not supported by XP (unless something changed within the last year). But I definitely have kept your link for the workarounds and will look into it.

    Thanks again.
    Bob

  15. #15
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,527
    Thanks
    1
    Thanked 614 Times in 550 Posts

    Re: Add/Remove Programs blank? / Fixed !!

    Bob,
    Keep this Symbios Logic Symbios 53C416 PnP SCSI Adapter Driver. The person who posted the driver claims it works with XP. As with anything having to do with computers YMMV


    Joe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •