Results 1 to 5 of 5
  1. #1
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    London, Gtr London, England
    Posts
    416
    Thanks
    0
    Thanked 0 Times in 0 Posts

    'My menu' disappears - sometimes! (Word 97/possibly 2000)

    Hi,

    I have template where I have added an extra menu with my options. I have also added couple menu items in the standard Help menu. For example:
    File Edit View Insert Format Tools Table 'My Menu' Window Help

    This all works fine but some of our users are complaining that from time to time the 'My Menu' and menu items under Help (which I added) disappear. I have seen this in action. The PC is slow enough to see WORD paint the menu item 'My Menu' and then it removes. ONLY the menu item I have added is removed - all other standard word menu items are displayed. But unfortunately, it doesn't happen all of the time. I can still access the menu items with the keyboard shortcuts (i.e. run the macros invoked by the menu items).

    Any ideas? Perhaps I need to run a macro to switch on the menu on OPEN and CREATE?

    Thanks

    Robie
    This is really baffling & I have looked for answers on Microsoft site and within the forum but nothing available.
    Thanks.
    Robie

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: 'My menu' disappears - sometimes! (Word 97/pos

    Does it occur only when Word starts up by loading a document based on your template (e.g., by double-clicking), or can it occur after Word already is running and a file based on your template is loaded using File>Open?

    I ask because the order in which global templates and add-ins are loaded at startup might help you pin down the bit of code that is "resetting" the menu bar (or whatever it is doing). The first suspect, in my mind, is always Acrobat PDF Maker, but you might want to temporarily remove all other global templates and COM Add-ins from the environment and add them back one by one. Arduous and boring, I know...

    If it can happen any time a document based on your template is opened, then there might be a piece of AutoOpen or Document_Open or similar event handling code that should be suspect. But this would be rare, and using File>Open after launching Word might be a viable workaround.

  3. #3
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    London, Gtr London, England
    Posts
    416
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'My menu' disappears - sometimes! (Word 97/pos

    Thanks for the response.

    I have seen it occur when I double-click on the template to create a NEW document. Unfortunately, I am in another office at the moment and need to go to another site to test this out. Also, as far as I am aware PDF Maker is not installed on that particular machine.

    As you suggested perhaps it is to do with how the document is opened on some of these machines, i.e. if WORD is open already then the menu is displayed correctly otherwise it doesn't display the menu. Also, this PC is definitely Windows XP but I don't know about other machines.

    I now also remember the following:

    1. Double-click on the template to create NEW document - Word is loaded but the menu appears and then disappears
    2. Double-click on the template again to create the second document - second document displayed WITH the menu
    3. Switch back to the first document & then back to the second document - the menu DISAPPEARS from the second document - hm????
    4. Switching between the documents seem to bring back and remove the menu but I can't quite remember the sequence.

    I guess I will have to visit the site and try out various things. But if you guys can think of anything else I would be grateful.

    Robie
    Thanks.
    Robie

  4. #4
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    London, Gtr London, England
    Posts
    416
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 'My menu' disappears - sometimes! (Word 97/pos

    You were absolutely correct. It was the PDF Maker 6.0 adding its own menu option to the main word menu. It then got rid of my menu.

    Now how do I solve this problem? I guess this particular PC will need to get rid of PDF Maker when using my template. I can't think of another way out.

    Thanks.

    Robie
    Thanks.
    Robie

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 28 Times in 28 Posts

    Re: 'My menu' disappears - sometimes! (Word 97/pos

    I'm afraid you're correct - it's either PDFMaker or your custom menu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •