Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Aug 2002
    Location
    Harrisburg, Pennsylvania, USA
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Mergefields in SOME headers not working (Word 2000 SR-1)

    I'm having problems with mergefields in a single document header, in a document which contains several sections (therefore, several headers). Let me try to explain clearly:

    The document contains three sections. Section 2 is continuous, so its header/footer do not appear. Section 1 and 3 headers are slightly different, but each contains two mergefields -- the exact same two mergefields. No first/odd/even headers and footers are used.

    Section 3 consists of an INCLUDETEXT field to draw in a separate document, and a bit of following text inside a frame. The separate document has no header and footer; those are being controlled by the first document. The INCLUDETEXT actually also contains a mergefield, because the separate document is not the same every time -- the mergefield brings in the correct path to the separate file, and that appears to be working splendidly.

    When I merge the document, the fields in the Section 1 header work perfectly, I get the data I'm looking for. However, the fields in Section 3 header do not merge at all. In fact, they come out looking like unlinked mergefields with no data. Something like <<if_pln>>.

    The crowning bit of weirdness: the merge document is being set up to run as part of an automated process, so the merge will actually be run by a macro. The tests I run through the macro show this result. But if I merge the same documents manually, with the same data, all of the header fields work perfectly. No problems at all.

    Sigh.

    Has anyone seen behavior like this, or have any suggestions what I might do about it? Thank you!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Mergefields in SOME headers not working (Word 2000 SR-1)

    There are several newsgroup threads about similar-looking problems. It seems to have been solved in Word 2002, at least I can't reproduce it there.
    Some of the newsgroup threads mention that mail merge fields in a text box in a header or footer may not work correctly in Word 2000. Does that match your situation?

  3. #3
    Lounger
    Join Date
    Aug 2002
    Location
    Harrisburg, Pennsylvania, USA
    Posts
    46
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Mergefields in SOME headers not working (Word 2000 SR-1)

    No, there aren't any text boxes involved in this case. Just ordinary paragraphs, and ordinary mergefields. I'm working around it now by using two SET fields in Header 1 to get the two mergefield results (as in { SET pln "{ MERGEFIELD if_pln }" }), and then putting bookmark fields in Header 3 rather than the mergefields themselves. For whatever reason, this is working. So I've got a workaround; I just wish I knew WHY it is happening. (But I've worked with Word long enough to know that this wish is not always granted <img src=/S/igiveup.gif border=0 alt=igiveup width=31 height=23> )

    I'll have a look through the newsgroups if I get a chance and see what may be seen. Thanks Hans!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •