Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Jan 2001
    Location
    Hamilton, Waikato, New Zealand
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Email form no longer working

    We have an Outlook form that once completed as well as sending the email message inserts certain data from feilds in the form into an excel workbook.
    The form was written while we were on a NT4 platform running Office 97.
    Now the users have been moved to Citrix network, Win2000 server running Office 2000, the form still sends the email but does not update the file. No file or directory names were changed in the change of platform, and those few of us still on NT/Office 97 can still have the form work.
    Are there any known problems that would cause this problem?

    I have included the code incase an error can be spotted there, but as I say it has been working fine.

    Any assitance (even ideas on where to start looking) wiil be much appreciated

    Andrew M

    Dim myXl
    Dim myWb
    Dim myWs
    Dim myCtrls

    Sub Item_Send

    Set myCtrls = Item.GetInspector.ModifiedFormPages("Message").Con trols

    Set myXl = Application.CreateObject("Excel.Application")

    Set myWb = myXl.Workbooks.Open ("gBdataUnderwriting Review.xls")

    Set myWs = myWb.ActiveSheet

    myWs.Unprotect

    startRow = myWs.Cells.SpecialCells(11).Row + 1

    myWs.Cells(startRow, 1) = myCtrls("ClaimNumber").Value
    myWs.Cells(startRow, 2) = myCtrls("PolicyNumber").Value
    myWs.Cells(startRow, 3) = myCtrls("ClientName").Value
    myWs.Cells(startRow, 4) = myCtrls("PolicyType").Value
    myWs.Cells(startRow, 5) = myCtrls("Happening").Value

    myWs.Protect

    myWb.Save

    myWb.Close

    myXl.Quit

    Set myWs = Nothing
    Set myWb = Nothing
    Set myXl = Nothing
    Set myCtrls = Nothing

    End Sub

  2. #2
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Email form no longer working

    Sorry, no hints as to your problem, but a little use of the With identifier might make the code a bit easier to read. Just a thought...
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  3. #3
    Gold Lounger
    Join Date
    Dec 2000
    Location
    Hollywood (sorta), California, USA
    Posts
    2,759
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Email form no longer working

    Have you stepped through the code in debug mode? Maybe that xls is read only now or in a read only folder?
    Kevin <IMG SRC=http://www.wopr.com/w3tuserpics/Kevin_sig.gif alt="Keep the change, ya filthy animal...">
    <img src=/w3timages/blackline.gif width=33% height=2><img src=/w3timages/redline.gif width=33% height=2><img src=/w3timages/blackline.gif width=33% height=2>

  4. #4
    Lounger
    Join Date
    Jan 2001
    Location
    Hamilton, Waikato, New Zealand
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Email form no longer working

    I have finally managed to get back to this one. After much harrasing of the IT dept I finally sussed the problem lies within the security settings of Office 2000 (service pack 2 again). IT have managed to get some of their own forms working so I now have then trying to tweak mine to work. Will let you know if a definate cause/solution is found.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •