Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Jan 2001
    Posts
    114
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Spell checking (Word Office 2003)

    I have built a template with 5 protected fields that must be filled in at the beginning after opening the document. After leaving the last field, I unprotect and unlink all the fields so the input text is now normal except that that it is never spell checked. I thought that it should be. How can I get these fields spell checked.
    I have thought of creating a range of the main text story and forcing that to be spell checked. Will this work? If so what coding do I require to create the range and start the spell checking? This code would be executed upon leaving the last field.
    Thank you for any assistance.

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Spell checking (Word Office 2003)

    You can use this instruction:

    ActiveDocument.Content.NoProofing = False

  3. #3
    2 Star Lounger
    Join Date
    Jan 2001
    Posts
    114
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell checking (Word Office 2003)

    Hans: Thank you for the very easy solution.
    Can you explain to me what condition fields are in after being unlinked but not considered by the spell checker?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Spell checking (Word Office 2003)

    When you create a form field from the Forms toolbar, Word automatically sets "Do not check spelling or grammar" for it. (Word doesn't check spelling in protected sections anyway) This remains after you have unlinked the field. You explicitly must turn off "Do not check spelling or grammar", either interactively (in Tools | Language) or using VBA.

  5. #5
    2 Star Lounger
    Join Date
    Jun 2003
    Location
    New Jersey
    Posts
    103
    Thanks
    6
    Thanked 0 Times in 0 Posts
    [quote name='HansV' post='477809' date='09-May-2005 20:03']When you create a form field from the Forms toolbar, Word automatically sets "Do not check spelling or grammar" for it. (Word doesn't check spelling in protected sections anyway) This remains after you have unlinked the field. You explicitly must turn off "Do not check spelling or grammar", either interactively (in Tools | Language) or using VBA.[/quote]

    Hello Hans,
    I have a similar question. I have a word 2003 document that I have form fields added. I have to protect the document so that users can't change the doc but then the spell checker is grayed out by default. How can I turn this on? I need a spell checker for my form. I attached a sample. The pw is test.
    Attached Files Attached Files

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts
    [quote name='Corden' post='765349' date='14-Mar-2009 03:46']Hello Hans,
    I have a similar question. I have a word 2003 document that I have form fields added. I have to protect the document so that users can't change the doc but then the spell checker is grayed out by default. How can I turn this on? I need a spell checker for my form. I attached a sample. The pw is test.[/quote]
    This question has also been asked on our Word forum in Post 765347. Please post any responses there.
    Please do not cross-post your question to multiple forums. See Rule 14.
    I have locked this thread so that we don't get two diverging sets of replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •