Results 1 to 7 of 7
  1. #1
    5 Star Lounger jujuraf's Avatar
    Join Date
    Jun 2001
    Location
    San Jose, California, USA
    Posts
    1,061
    Thanks
    0
    Thanked 0 Times in 0 Posts

    web page not open new window (IE 6.0)

    I have a web page I wrote which has a link that opens a new page, this works fine for me on my PC but not on my husband's. We both have IE6.0 but when he clicks the link, a new window opens and the 'new' page gets loaded, but less than a second later this same new web page gets loaded in the current web page (the window that was already open) and not in a new second window. The result is that this new page has now replaced the contents of the previous page and there is no Back button (since it was opened with target="_blank"). I can't see any settings in IE that would affect this and the code has target="_blank" so what more could I do?

    Also, he has no history whatsoever in his Address bar. It gets deleted every time he closes and re-opens IE.

    Any ideas what is causing this?

    Thnx, Deb

  2. #2
    Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: web page not open new window (IE 6.0)

    See if this setting in Tools>Internet Options changes that behavior.
    Attached Images Attached Images
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

  3. #3
    5 Star Lounger jujuraf's Avatar
    Join Date
    Jun 2001
    Location
    San Jose, California, USA
    Posts
    1,061
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: web page not open new window (IE 6.0)

    Nope, turning on (or off) 'reuse windows' did nothing (this setting is off on my PC and I have no problems opening new windows). This setting was already off (which makes sense to me if I understand its purpose). The really weird thing is that IE even refuses to open a new window when I use SHIFT key when I click on a link. Even if I try and force it by doing a right-click on the link and select 'open in new window' it still refuses to open the page in a new window. For a split second, I can see the new window get opened, but it immediately closes and the page loads in the current window.

    I also wonder why his history list is always empty when he launches IE for the first time.

    Since this web site that I'm talking about is for his home-based business, I'm concerned that other users might have the same problem. If they do, it make the site harder to use. I can certainly get rid of the target="_blank" but then the user has to hit the Back button three times to get back to his main site and I don't like that at all.

    This is very odd indeed. Any other ideas? I'll cruise the MS KB but I always have a hard time finding anything useful there (even when I know what I'm looking for).

    Thnx, Deb

  4. #4
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: web page not open new window (IE 6.0)

    I think the 'history list is always empty' issue may be caused by having the 'Days to keep pages in history' set to 0 (under Tools > Internet Options > General).

    Is the window being opened less than full-screen? - it may be being detected as a pop-up...

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: web page not open new window (IE 6.0)

    IE does not automatically close windows opened using TARGET="_blank", even in SP2. Sounds as though a badly designed third party pop-up blocker could be to blame.

    Added: They magic keyword _blank should never be used as the name of a window opened using JavaScript's window.open, but if it were, that might cause IE to be confused and load both a new window and the existing window. Just speculation on my part; can't test it right now.

  6. #6
    5 Star Lounger jujuraf's Avatar
    Join Date
    Jun 2001
    Location
    San Jose, California, USA
    Posts
    1,061
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: web page not open new window (IE 6.0)

    I tried everything I could and still IE in this one PC (with Win2k) refuses to open a new window (even right-click fails). This is what I've done so far.

    a) followed MSKB article http://support.microsoft.com/default.aspx?...kb;en-us;180176
    (rebooted several times)
    [img]/forums/images/smilies/cool.gif[/img] uninstalled IE (via Control Panel, add/remove Windows components since it doesn't show up in the list of programs)
    (rebooted)
    c) reinstalled IE (via same add/remove Windows components menu)
    (rebooted)
    d) downloaded IE 6 + SP1 from MS site and forced it to re-install itself
    (rebooted)

    Even after all this fun, IE still refuses to open a new window on right-click ("open in new window") or when the link has target="_blank" set. <img src=/S/brickwall.gif border=0 alt=brickwall width=25 height=15>

    As to pop-up blocker, that PC has Google pop-up blocker and I even uninstalled it (and rebooted), but that didn't fix anything either.

    BTW. The history setting is 7 days but it acts like it's 0 days. I changed it to 5, closed IE, reopened IE and still it doesn't remember anything between sessions.

    There is obviously something deep inside that is messed up but it looks ike there's no fix other than a complete re-image of the PC and that's not something I want to do right now. I guess we'll live with this annoyance for now.

    Thanks for all your ideas. I'm giving up for now.
    Deb <img src=/S/bummer.gif border=0 alt=bummer width=15 height=15>

  7. #7
    5 Star Lounger jujuraf's Avatar
    Join Date
    Jun 2001
    Location
    San Jose, California, USA
    Posts
    1,061
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: web page not open new window (IE 6.0)

    One side effect of all my attempts at fixing this problem is that now I can't close IE at all <img src=/S/crazy.gif border=0 alt=crazy width=15 height=15> <img src=/S/crazy.gif border=0 alt=crazy width=15 height=15>. Clicking the "X" in top right corner does nothing as does File/Close. <img src=/S/bananas.gif border=0 alt=bananas width=33 height=35>

    Jeessh, man, what's up with that? <img src=/S/dizzy.gif border=0 alt=dizzy width=15 height=15> Should of left well enough alone, eh? At least before I could close IE.

    Ah, well, I guess I'll use Mozilla instead from now on.

    Thnx,
    Deb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •