Results 1 to 9 of 9
  1. #1
    3 Star Lounger
    Join Date
    Mar 2001
    Location
    Cheltenham, Gloucestershire, England
    Posts
    214
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Not displaying whole hyperlink in report field (2000 (in 2003))

    I have a report which displays a field which is formatted as a hyperlink. Unfortunately it displays with the contents of the field and the hyperlink "April Document List #AprilDocs20050404" when all I want to see is "April Document List". It looks fine in the query (except for the underline).

    How can I display the field contents as I required please?

    Thanks
    Roberta

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    What is the Control Source property of the text box that displays the hyperlink field?

  3. #3
    3 Star Lounger
    Join Date
    Mar 2001
    Location
    Cheltenham, Gloucestershire, England
    Posts
    214
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    the control source is the field from the query my report is based upon. The query uses the table field (doc Name) which is a hyperlink field. So viewed in a table or form it says e.g."April Document List" (naturally in blue and underlined) - but for some reason in a report it picks up the hyperlink file name as well?

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    That's strange - hyperlinks display "normally" in reports for me. Could you post a stripped down copy of your database, with just enough left to demonstrate the problem? See <post#=401925>post 401925</post#> for instructions.

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    Something seems to have gone wrong - there's no hyperlink field in any of the tables, and no report.

  6. #6
    3 Star Lounger
    Join Date
    Mar 2001
    Location
    Cheltenham, Gloucestershire, England
    Posts
    214
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    Opps - try this one -

  7. #7
    3 Star Lounger
    Join Date
    Mar 2001
    Location
    Cheltenham, Gloucestershire, England
    Posts
    214
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    herewith cut down version.
    Just with tables
    query and report

    Thanks for your help
    roberta

  8. #8
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    It seems to work OK in a report based on the table or on a query based on the table (only), but as soon as the query is based on more than one table, things go wrong. I don't know why that happens, but here is a workaround:
    - Change the name of the DocumentType text box on the report to (for example) txtDocumentType.
    - Set the Control Source of the text box to
    <code>
    =IIf(Not IsNull([DocumentType]),Left([Documenttype],InStr([DocumentType],"#")-1))
    </code>
    This extracts the first part (the display text) from the hyperlink field if it isn't empty.

  9. #9
    3 Star Lounger
    Join Date
    Mar 2001
    Location
    Cheltenham, Gloucestershire, England
    Posts
    214
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Not displaying whole hyperlink in report field (2000 (in 2003))

    Many thanks - this has worked brilliantly. This has got me some brownie points ahead of my 3 month appraisal tomorrow!!
    Regards
    Roberta

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •