Results 1 to 9 of 9
  1. #1
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    Bismarck, ND, USA
    Posts
    451
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Stop Spellcheck (Wd 2003, SP1)

    I have to open a large document (over 400 pages) and I do not want it spell checked. I stared by using the Tools/Options menu to uncheck check spelling and grammar as you type, but it continues to check the document. Since there are settings under Tools/Language and with the style, what is the best way to ensure that NO spellcheck occurs?
    egghead

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    How about a little direct formatting? If you select all and use Tools>Language>Set Language..., then tick the "Do not check spelling" checkbox, that should cause Word to bypass the selected content when checking. You can reverse the process if you ever want to check in the future.

    DANGER: anything pasted from this document into other documents will retain and spread this invisible formatting attribute!

  3. #3
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    Bismarck, ND, USA
    Posts
    451
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    That was one of the things I was looking at. When I first open the dialog box there is a green square in the check box. Do you know what that means?

    If I click that I can change it to a check mark. But then if I go to the Styles and Formatting task pane to check the style, the box is not checked there. (the style is called Plain Text). If I check it, click automatically update and add to template, the spell as you go icon appears and the pen starts "squiggling" like it's running spell check!!!
    egghead

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    The green square means both checked and unchecked. It appears if you have selected some text that has the box checked and other text that doesn't at the same time.

    You get this symbol on many other dialogue boxes too, for example try setting some text to bold and looking at the format font dialog box when you have the whole paragraph selected.

    StuartR

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    I'm running Word 2002 at the moment. You should be able to change the setting directly in your style definition if you expect to apply this change to similar documents in the future. Modify style>Formatting drop-down>Language...

  6. #6
    4 Star Lounger
    Join Date
    Mar 2001
    Location
    Bismarck, ND, USA
    Posts
    451
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    Edited by HansV to reduce image in size - please don't post images over 640 x 480 pixels

    I have gone into the style, modified the Language setting so Do not check spelling or grammar is checked. The icon continues to show with the pencil squiggling <img src=/S/hairout.gif border=0 alt=hairout width=31 height=23>

    I just want it off!
    Attached Images Attached Images
    egghead

  7. #7
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    Perhaps I will delay my upgrade to Word 2003. <img src=/S/laugh.gif border=0 alt=laugh width=15 height=15> I'll take a look at this on my home PC, which does have Office 2003, but it just doesn't sound right to me that you could turn off spell checking, AND mark "no proofing," AND still have red (or green) squiggly underlines.

  8. #8
    Bronze Lounger
    Join Date
    Jan 2001
    Location
    Melbourne, Australia
    Posts
    1,294
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    HI

    Yes I had the same issue.
    Within Word I was opening large word docs 400-600pages & the docs alot of technical references that Word automatically detected as spelling errors - therefore on the open Word would do a spell check. Howver due to so many unrecognised words that MS-Word couldnt detect -
    Word is attempting to perform a spell check and there are however there are so many Words in this file Word doesnt recognise, therefore Word displays another error message box on the amount of 'errors. The Workaround is for this document Normal style turn off check Spellng & Grammer.

    I've used the below code as a workaround.

    ActiveDocument.Styles("Normal").NoProofing = True

    However in Word I cant seem to find where/how this setting is set. anyone?

    diana
    note: this was in WordXP.

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Stop Spellcheck (Wd 2003, SP1)

    My previous post and egghead's reply show the menu path and dialog, respectively, to set this. However, at least for egghead, it doesn't seem to be working. Does it work in your document?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •