Results 1 to 7 of 7
  1. #1
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Stubborn Read Only (WXP Home SP1)

    Trying to install a program that seemingly must first install the "installShield Engine (iKernel.exe), and I get a message saying it can't be installed. I checked, and it is trying to install it in Crogram filesCommonInstall Shield. However all the files are marked Read Only, and when I try to uncheck the Read Only condition it pops right back. Surely there must be an option somewhere that allows me to create a folder in Common.

    Any suggestions?

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Stubborn Read Only (WXP Home SP1)

    The read only attribute on a folder is used for a different purpose than on a file. All folders in XP have the read only attribute set. Search the lounge for prior discussions about this.

    Joe
    Joe

  3. #3
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Stubborn Read Only (WXP Home SP1)

    OK. I understand that Read Only is set for folders. If that's not the problem, then what do I do to get "permission" to intall the "Install Shield" program?

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Stubborn Read Only (WXP Home SP1)

    Can you get more information other than 'can't be installed' such as a detailed log? What is the program? Is the User trying to install the program an administrator?

    Joe
    Joe

  5. #5
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Stubborn Read Only (WXP Home SP1)

    I'm trying to install a wireless utility program -- one that reports the status of a wireless network interface card.

    The messate is something lilke "Cannot install the installShield Engine (iKernel.exe)," which, I assume, is a module that must be installed before the program will install. It is trying to install it in Crogram filesCommonInstall Shield. The message indicates that I don't have the proper permissions. However, I'm logged in as the system Administrator. At that point I'm at a dead end. I've installed the same program on several other computers and didn't run into this problem with any of them.

  6. #6
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Stubborn Read Only (WXP Home SP1)

    You may find some help here at InstallShield Consumer Central, such as IKernel.exe Could Not Be Installed.

  7. #7
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    Escondido, California, USA
    Posts
    1,458
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Stubborn Read Only (WXP Home SP1)

    Hi Lief, thanks for the suggestion, but I finally got tired of the whole thing and reinstalled XP. That cleared up the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •