Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Date issue in Combo Box (WIN XP/Access 97)

    In the table:
    FieldName - Month_Year
    Data Type - Date/Time
    Format - mm/yyyy

    On the form:
    Field Name: cboMo_Yr
    Field Type - Combo Box
    Format - mm/yyyy
    Row Source - SELECT tblRECRED_MONTH.MONTH_YEAR FROM tblRECRED_MONTH ORDER BY tblRECRED_MONTH.MONTH_YEAR;

    When I click on the combo box, the month/years are listed correctly.
    01/2005
    02/2005 etc

    But once I click on one, it appears as 2/1/2005

    It's dropping the leading zero and adding /1

    What setting am I missing?

    Thank you very much.

    Michael

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Date issue in Combo Box (WIN XP/Access 97)

    You're not missing anything, it's the way Windows works. When you edit a date, it's displayed in the default format (m/d/yyyy). Once you leave the combo box, it will be displayed in the selected format again.
    If you don't like it, you'll have to use separate month and year combo boxes, or make month_year a numeric or text field. The latter is unattractive, however, since you'd have to perform all the data checking yourself that is automatic for a date/time field.

  3. #3
    4 Star Lounger
    Join Date
    Jun 2001
    Location
    Sacramento, California, USA
    Posts
    491
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Date issue in Combo Box (WIN XP/Access 97)

    Thanks Hans !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •