Results 1 to 9 of 9
  1. #1
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Can't delete linked tables from server (2000)

    Hi!

    I'm totally stumped. I'm attached a stripped down database. It will open to frmSalesAdjustments. There is sfrmSalesAdjustments in the form. The user enters the store number (to demo you can use 1302, 1797,3137, 3145, 5081). They enter the month date range for the invoices (in this case use 7/1/05 to 7/31/05). The linked tables are saved on the server and there are 4 workstations that are use the database. All has been going fine for the past 2 months since going live. Now all of a sudden they are unable to delete the records. The piece that confuses me more is that if I test it on a computer where the linked tables are in the same directory as the database, I am able delete the records. If I put the linked tables on a different drive altogher I am unable to delete. What is wrong???

    Thanks,
    Leesha

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Can't delete linked tables from server (2000)

    I have no problems deleting records, whether I put the backend in a folder on the same drive as the backend or in a folder on a different drive. Are you sure you and the other users have sufficient permissions on the folder containing the backend? Everyone must have read/write/create/delete permissions, otherwise the backend will become read-only.

  3. #3
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't delete linked tables from server (2000)

    Everyone is using an identical version of the software. You have what they have in a stripped down version. OH God, if you can't find anything wrong I'll never find it. I have no clue as to what changed in the past two months.

    Leesha

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Can't delete linked tables from server (2000)

    I'm not talking about the version of the software. You should check the permissions users have at the Windows level on the folder containing the backend database.

  5. #5
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't delete linked tables from server (2000)

    I haven't set permssions. And I'm running into the same thing on my home network. To make matters more confusing for me, I can delete other records from other tables.

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Can't delete linked tables from server (2000)

    I'm sorry, I don't see anything in the databases themselves that would prevent deletion of records, so I suspect it must be something external.

  7. #7
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't delete linked tables from server (2000)

    Thanks anyway Hans. I appreciate your help!

    Leesha

  8. #8
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Sint Niklaas, Belgium
    Posts
    2,778
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Can't delete linked tables from server (2000)

    Leesha,

    In the query qrySalesAdjustment the tables are linked by the field Store_ID. As Store_ID in not the primary key in the tblStoreDemographics table, the query is not updatable and you can't modify or delete anything in the query. To solve this, set the primary key in tblStoreDemographics to Store_ID.
    Francois

  9. #9
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Can't delete linked tables from server (2000)

    Hi!

    I ended up deleting the entire link to tblStoreDemographics as in the long run it wasn't critical. What I don't understand is why it worked for 2 months and then all of a sudden not at all and why it worked on some computers but not on any of the computers at this site.

    Leesha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •