Results 1 to 3 of 3
  1. #1
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    Brookings, South Dakota, USA
    Posts
    449
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Under High Security buttons don't work

    Hi All,
    I've got a set of asp pages used to register students into the ResNet database. Testing things out under different browser security settings I ran into a problem. The following buttons....

    <INPUT type=button id="EditInfo" name="EditInfo" value="Edit Information" class="ButtonBlue" style="WIDTH: 150px" onclick="location.href='EditResNetInformation.asp' ">
    <INPUT type=button id="GoToGetMAC" name="GoToGetMAC" value="Continue" class="ButtonBlue" style="WIDTH: 150px" onclick="location.href='GetMACNow.asp'">

    ....on page ReadySetGetMAC.asp (in text in the attached file) do not do anything in the onclick when Internet Explorer has High Internet zone Security. No error is given.....it looks as if the page has only been refreshed.

    GetMACNow.asp (also in text in the attached file) is 1 of the 2 pages which can be called from the ReadySetGetMAC.asp page. Right now it is nothing fancy at all.

    If I place http://<MyIPAddress>/WebRegTest/GetMACNow.asp directly into the address I can go to GetMACNow.asp as I can go directly to the 2nd page when directly addressed.
    I seem to be able to go between other asp pages in this project with nothing similar happening.
    Also the pages seem to work correctly when using Firefox or Netscape, but I'm not certain I've got them set to their highest security setting.

    So......why don't those buttons work, in particular (I guess), under IE's High Security settings and how do I get them to work under these settings?

    Thanks.

    gdr
    Attached Files Attached Files
    <IMG SRC=http://www.wopr.com/w3tuserpics/gdrezek_sig.jpg>
    "Those who dance are considered insane by those who can't hear the music" - George Carlin

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Under High Security buttons don't work

    Internet Explorer's "High" setting probably disables all JavaScript and VBScript from running. Your buttons, rather than being simple links, use JavaScript to load another page. Since you don't really need JavaScript for this particular application, you might prefer to substitute something along these lines:

    <code>[img]imageofbutton.gif[/img]</code>

    I realize that is not as attractive. You could have this as a fallback and create the pretty button with JavaScript so that users with a lower level of security have a better experience:

    <code><script type="text/javascript">
    document.write('<INPUT type="button" id="EditInfo" name="EditInfo" value="Edit n ' +
    'Information" class="ButtonBlue" style="WIDTH: 150px" ' +
    'onclick="location.href='EditResNetInformation.asp '">');
    </script>
    <noscript>
    [img]imageofbutton.gif[/img]
    </noscript></code>

    Make sense?

  3. #3
    4 Star Lounger
    Join Date
    Jan 2002
    Location
    Brookings, South Dakota, USA
    Posts
    449
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Under High Security buttons don't work

    Hi Jefferson,
    <hr>Make sense? <hr>
    Sure does! I should have guessed it would have had to be some type of scripting, but I would have (heck, I did!) passed right on by the form controls. And you're correct in that I don't need Javascript for this so your substitution comes in mighty handy.
    Thank you very much.

    gdr
    <IMG SRC=http://www.wopr.com/w3tuserpics/gdrezek_sig.jpg>
    "Those who dance are considered insane by those who can't hear the music" - George Carlin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •