Results 1 to 6 of 6
  1. #1
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Control formatting on report (Access XP)

    I have an unbound control on a report with the format set to $#,##0.00;($#,##0.00)<font color=red>;"";""
    When I populate this control it does not apply the formatting. I only see the number unformatted.
    Any ideas?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Control formatting on report (Access XP)

    What is the Control Source of this control (since it's unbound I assume it is a calculated control)?

  3. #3
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts

    Re: Control formatting on report (Access XP)

    How are you populating it?

    I used exactly the same format on an unbound control then gave it a value by just setting its control source to a fixed value, and it behaved as you would want.
    Regards
    John



  4. #4
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Control formatting on report (Access XP)

    I move a column of a combo box into the control, eg...

    OsAmt = ComboClient.Column(4)

    The value in this column is 179.

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Control formatting on report (Access XP)

    Try

    OsAmt = Val(ComboClient.Column(4))

    to force the value to be interpreted as a number.

  6. #6
    Platinum Lounger
    Join Date
    Dec 2001
    Location
    Melbourne, Australia
    Posts
    4,594
    Thanks
    0
    Thanked 27 Times in 27 Posts

    Re: Control formatting on report (Access XP)

    I was too slow in coming back to this forum, I had solved it a couple of minutes ago, I did:

    TextOSAmt = Val(ComboClient.Column(8))

    Thanks anyway Hans.

    Thanks for your input John.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •