Results 1 to 3 of 3
  1. #1
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Form doesn't show all Data (2002)

    Hi,

    I'm working with a form that has 3 subforms. Two are working fine. The third form, fmIncome, works fine on its own but once in the main form it leaves out data. Specifically, it is supposed to show all the rows in the table and give a total income based on the total rows entered. I've set the properties to all records and continuous but nothing works. I've repositioned it all over the form to see if that helped but nothing. What am I missing? The form with the problem is frmIncomeAnnualExpensesDataEntry.

    Thank,
    Leesha

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Form doesn't show all Data (2002)

    Both the main form and frmIncome are based on tblIncome.
    Main form and subform are linked on ID, so the subform will display data from the same record as the main form.
    If you want the subform to display ALL records from tblIncome, you must clear the Link Master Fields and Link Child Field properties of the subform as a control on the main form (in the Data tab of the Properties window). But that will cause the subform to be independent from the main form.

  3. #3
    Silver Lounger
    Join Date
    Jan 2002
    Posts
    1,615
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Form doesn't show all Data (2002)

    Thanks! Chalk it up to another learning experience! Didn't even consider that one!

    Leesha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •