Results 1 to 3 of 3
  1. #1
    Star Lounger
    Join Date
    Aug 2002
    Location
    Wichita, Kansas, USA
    Posts
    71
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Outlook Public form rules (2000)

    We have a public folder that has a form associated with it. When the user opens the form and clicks "Post", there are rules that forward the post to another public folder and delete it from the current public folder.

    I am trying to create an "advanced" rule via the Properties - Administration tab - Folder Assistant button - Add Rule button - Advanced button. I have tried using both "Selected Forms" and "Folder" to display the form fields and add the condition. I am trying to compare a form field to text that was populated in the field via a drop down list. So I have a check mark next to the field name and in the condition box I put the text I am looking for. When I click OK back to the Rules dialog box, everything looks fine.

    But, whenever I click back out to the Administration button using OK buttons, then go back in to check the condition, it is no longer there. If I used the "Folder" option to display the fields and put in the condition, it gives an <unavailable> in the rule list. If I used the "Selected Folders" option to display the fields and put in the condition, it drops the condition in the rule list.

    I have had these type of rules work before, but notice they have been with yes/no fields.

    Can anyone tell me why it isn't saving the conditions?

    Thanks,
    Patty

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Outlook Public form rules (2000)

    This is over my head, but I can share this: based on my limited experience developing forms, they sometimes behave strangely. Using Save As and creating a new form sometimes solves the problem of not being able to save changes.

  3. #3
    Star Lounger
    Join Date
    Aug 2002
    Location
    Wichita, Kansas, USA
    Posts
    71
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Outlook Public form rules (2000)

    Edited by HansV to provide link to MSKB article using <!t>[mskb=839856]<!/t>

    I finally found the answer via <!mskb=839856>Microsoft Knowledge Base Article 839856<!/mskb>.

    If you apply an advanced rule condition comparing a field for a string, with a form published through Outlook 2002 (or in my case 2003), the string disappears from the rule display, but will actually still work. The workaround says to re-publish the form with Outlook 2000. I did that and it has fixed the problem.

    Hope this will help anyone else who runs across the same thing.

    Patty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •