Results 1 to 3 of 3
  1. #1
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts

    VBE Toolbox Controls (Word 2002)

    If I add an additional control (specifically Date & Time Picker) to the Toolbox in the VBE, does that control exist only in the VBE where I added it? Does it (or should it) appear in the Toolbox (on another PC, for example) when I open a template (or user form) where that control is in use?

    A template which has a D/T Picker was later edited on another PC. The D/T picker is not in the Toolbox even when that template is opened in the VBE on the PC where it was created. Perhaps the issue is the particular control. I had a problem previous where I was unable to set the default date when the form displayed. The control was hidden by default )Visible = False in Properties), and that was the problem. I set Visible = True in Properties, and in the Form Activate code I set the default date and then set Visible = False. Properties of most controls that I've worked with can be set even if the control is not visible.

    Thanks,
    Richard

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: VBE Toolbox Controls (Word 2002)

    Using controls such as the Date/Time Picker is tricky, since they are not installed on all PCs.

    As far as I know, modifications to the Control Toolbox are stored at the user level, not with a document or template.

  3. #3
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts

    Re: VBE Toolbox Controls (Word 2002)

    Yes, that apears to be the case. I've edited this particular template many times, but I haven't had occasion until today to edit the user form which contains the D/T picker. When I went to work with the user form (change the caption), the VBE closed, and Word closed and re-started. There was an error message which flashed.. something about an invalid path. The D/T picker was not in the Toolbox of the PC I was using, and I'm guessing that VBA was "confused" about the control in the template which didn't seem to be an attached control. I've recovered everything, suffering only a little lost time.

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •