Results 1 to 8 of 8
  1. #1
    Star Lounger
    Join Date
    Sep 2001
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Spell-check keeps turning off (Word 2002 SP3)

    I have a document wherein spell-check is disabled. I can trace the issue to Tools - Language - Set Language, which, when the entire document is selected, shows "do not check spelling or grammar" is partially ("greyed out") box checked off. When I clear that check box when the whole document is selected, then hit ok, I expect the spell check to come back. But it doesn't, and when I check the Language tools again, the "do not check" box is enabled again. What gives?

    Many TIA

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    If you clear the attribute for one paragraph and type an intentional misspelling into that paragraph, is it detected? Just wondering whether for some reason trying to apply it to the entire document is the problem, rather than your entire text being resistant to the setting... Note that when you use Insert>Date or insert a date field through the fields dialog that the field typically is marked no proofing, and this may resist being changed. Not sure whether other field codes behave in a similar manner.

  3. #3
    Star Lounger
    Join Date
    Jan 2001
    Location
    Los Angeles
    Posts
    78
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    Two things to try:

    1. instead of highlighting the entire document, check out the Normal style. make sure the "do not check" language attribute is not set on this style. Check any other style you may be using (check the style on a sample paragraph where the spelling is not running.) Once this is cleared, you may have to press Ctrl-Spacebar on a these paragraphs, to clear any direct formatting off the characters.

    2. did you "reset" spelling? (Tools, Options, Spelling, Recheck Document).

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    Do you have any form fields in the document?

    Have you tried using Find to search for text marked with this attribute?

    StuartR

  5. #5
    Star Lounger
    Join Date
    Sep 2001
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    Thanks for responding.

    I tried your suggestion (as well as others suggested in this thread) as follows. I selected the first para, checked the languages attribute, and the "do not check" was NOT enabled (so there was nothing to clear). I then clicked re-check in options, ran the spellcheck on the selected para, and it failed to pick up obvious errors that I embedded as a test.

  6. #6
    Star Lounger
    Join Date
    Sep 2001
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    <<Have you tried using Find to search for text marked with this attribute?>>
    Yes. It keeps finding only two instances of that attribute - in the footer, at page nos. 3 and 22. When I set up a Find and Replace with the "do not check" attribute as the former and the "check spelling and grammar" as the latter, the change again does not "stick". Word keeps reporting that it made one replacement, but it will keep making that one replacement everytime I click Replace. Because evidently it keeps finding it.

  7. #7
    Star Lounger
    Join Date
    Sep 2001
    Posts
    58
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    Applying all the advice I received (except the one about checking the attribute in Normal and other Styles - I did not know how to go about that), I deleted the page # footers, turned track changes off and on, reset the spellcheck option, and it finally reactivated. Now, one more problem - spellcheck is ignoring the comments. How do I get those included again? Thanks!

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Spell-check keeps turning off (Word 2002 SP3)

    Please check a single comment and make sure that it doesn't have the "do not check spelling and grammar attribute".
    Can you post a small (non confidential) sample of your document so we can try to see what is wrong.

    StuartR

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •