Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    NavMan iCN510 - Maps don't load

    I have a NavMan iCN 510 with Windows CE operating system. The maps do not load from the memory card.

    If anyone is familiar with such devices can you tell me how to restore the map loading facility? The NavMan Web site hasn't yielded me any help & a message to Technical Support was acknowledged without a reply yet.

    Malcolm Walker

  2. #2
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: NavMan iCN510 - Maps don't load

    Hi Malcolm

    Shot in the dark here but is the SD card seated correctly in the slot as I know these have the habit of popping out sometimes unnoticed, this happened with my Ipaq and I was swearing miserably at it until Jezzarette 2 'fixed' it for me.
    Jerry

  3. #3
    3 Star Lounger
    Join Date
    May 2003
    Location
    Mid-Cheshire, England
    Posts
    275
    Thanks
    1
    Thanked 3 Times in 3 Posts

    Re: NavMan iCN510 - Maps don't load

    Thank you for your message & suggestion. It's a good point - a problem I have experienced, twice, with the card not being seated correctly & even falling out of its slot. Panic - It took quite a search to find it!

    In the meantime I have deleted from & added to the maps & reloaded the software onto my computer & the NavMan. As a result & for no apparent reason it is working normally again. For which I am very thankful. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •