Results 1 to 12 of 12
  1. #1
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Table Paste Issue (WordXP)

    We have experienced lots of problems pasting tables between documents. The paragraph style formatting is usually lost. Attached is a copy of the original document which contains the table.
    Attached Files Attached Files

  2. #2
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Here is a copy of the document that won't accept the pasting into. All the style formatting is lost.

    What is going wrong?
    Attached Files Attached Files

  3. #3
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Table Paste Issue (WordXP)

    Very strange. Because randomly, it will work. Once it worked after I visited the Macros dialog (but didn't run any macros). Another time it started working after visiting the Print dialog and confirming that I had a valid printer and clicking Close. In another test, I copied, converted to text, and re-created your table below the original (in the FROM document). When I selected both tables for pasting, both were formatted correctly. Maybe the styles have become corrupted in the table? These things can be difficult to debug without more insight into the document's inner workings than can be gained from playing around and checking an HTML export and the results of using the Recover Text... filter.

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    I tried it with Word 2003 & had no problem. No formatting was lost. Perhaps you are pasting it as Paste Special/Unformatted; that would account for it. When you paste other items, do you have the same problem? If so, perhaps your paste command has been changed. Try it using Ctrl+V & also using Edit/Paste. If you're still having problems, check out <post#=197827>post 197827</post#>.
    Cheers,

  5. #5
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    I found a suggestion on the internet that saving a document as RTF and then opening it in Word would often fix these types of problems. I did this and it worked really well on the sample document. I wrote a macro to save it as RTF and open as Word and then copy and paste all the text. However, the macro doesn't fix it.
    sFilename = ActiveDocument.FullName
    ActiveDocument.SaveAs FileFormat:=wdFormatRTF
    ActiveDocument.Close
    Documents.Open sFilename
    activedocument.range.copy
    onewdocument.paste

  6. #6
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Another thing to look out for: You'll loose the corresponding font formatting if the "Normal" paragraph style has been modified in the document you paste into.
    So if the "Normal" style has a different font than "Times New Roman", you'll loose the font. If "Normal" isn't color "automatic", you loose the color...

    That's because Normal is always applied to all cells in the table (unless you apply some other paragraph style), but Normal only doesn't affect the table formatting (or said differently the table style only "wins" against Normal) if Normal isn't modified.

    I can paste fine in Word2003 also, but maybe the Asian font settings of "Normal" in the document you paste into are messing in your version?

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16> Klaus

  7. #7
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    When you pasted fined in Word2003, did you open both the documents provided and paste from one into the other? I tried this on a computer with Word2003 and it didn't work.

    That is interesting that you mentioned that normal is applied to all cells in the table. Is it possible that the styles within the table were all character styles (not paragraph styles), which is why they didn't paste in properly, and perhaps took on normal style?

    I did find that by saving the document as RTF and opening it, I could then paste everything into the other document successfully, which suggests that it might have been a document corruption issue. However, i couldn't programmatically do this... and I tried endlessly, but it just wouldn't work. So the manual fix seems the only solution for now. That is a pity because it happens often and I don't know the cause.

  8. #8
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Pasting definitely worked fine for me. I just tried it again in Word2003 to be sure.
    (added) I'm on SP2.

    Maybe have a look at "Tools > Options > Compatibility"? Some of the compatibility options might mess up things. Together with the old behavior of previous versions, they sometimes bring back bugs of the old versions.

    You definitely had different paragraph styles applied, no character styles.

    It was only a guess that the new table styles might complicate things. As mentioned, table styles work wonky if you have a customized "Normal" paragraph style in your document (or in your case, in the document you paste into).
    So if I use tables, I try to use a default, uncustomized "Normal" paragraph style.

    If saving in RTF format fixed things, it may have been some corruption. Though there are some features (mostly arcane stuff... say some Asian typography stuff) that just isn't saved in RTF format, and gets lost... sometimes not a bad thing <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16> Klaus

  9. #9
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Each of our documents seems to have a different set of compatibility options. That probably explains why there are so many issues. I changed all the compatibility options to Word 2002 and saved the documents - but the problem continued...
    However, I noticed that after I use paste special as "picture", and then paste, it always works. See the attached document. Why might this fix the problem?
    Attached Files Attached Files

  10. #10
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    No idea!

    It looks like the first times you pasted, all the paragraph styles in the table got lost, but the manual formatting was kept.
    I haven't seen that happen, and wouldn't know any explanation for it than bugs.

    It does seem to be fixed in Word2003, at least with the latest service packs: I still couldn't reproduce it there, even with changing all compatibility settings, AutoFormat/AutoCorrect options, or "Tools > Options > Edit" options.

    Klaus

  11. #11
    5 Star Lounger
    Join Date
    May 2001
    Location
    Stuttgart, Baden-W, Germany
    Posts
    931
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Another idea that might lead to a better work-around for the bug:
    Does it still happen if you copy all styles from the doc you paste from to the doc you paste into first (Tools > Templates and Add-Ins > Organizer)?
    Edited: Should have been the other way round... You likely don't want to mess with the styles in the target document.

    <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16> Klaus

  12. #12
    Star Lounger
    Join Date
    Jun 2005
    Posts
    87
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Table Paste Issue (WordXP)

    Yes it still happens even if I copy all the styles from the destination document into the original document. I need to be able to fix this problem with a macro because it happens in a large number of the documents that we have. The 2 manual workarounds that we have so far:
    a) Saving the original document as RTF and opening it
    [img]/forums/images/smilies/cool.gif[/img] Pasting the table into the document as a picture and then it pastes properly after that.
    I have tried programming (a) but it won't work when I run it. So perhaps I will have to write a 'workaround' macro to paste the table as a picture, then to paste it. Any better suggestions would be greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •