Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Jan 2001
    Posts
    313
    Thanks
    0
    Thanked 0 Times in 0 Posts

    mail merge 0's (Excel/Word 2003)

    I am trying to help a user with this problem. She is trying to do a mail merge with zip codes. The data is in a spreadsheet in Excel. She opens Word - starts the mail merge and when she chooses the spreadsheet, the 0's in the beginning of a zipcode are not there. They are listed in Excel though. When she completes the merge, they are still missing. Any suggestions? This works for a few people in her office. I cannot get it to work either.

    Thanks

  2. #2
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Weert, Limburg, Netherlands
    Posts
    4,812
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mail merge 0's (Excel/Word 2003)

    It might help to preceded the zip codes with a single quote.
    Jan Karel Pieterse
    Microsoft Excel MVP, WMVP
    www.jkp-ads.com
    Professional Office Developers Association

  3. #3
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: mail merge 0's (Excel/Word 2003)

    One possibility is to add a formatting switch to the mail merge field in the merge document:
    - Right-click the merge field.
    - Select Toggle Field Codes from the popup menu.
    - You'll see something like { MERGEFIELD Zip } or { MERGEFIELD Zip *MERGEFORMAT }
    - Insert a space followed by <code># "00000"</code> after the field name (this is for a 5 digit zip code)
    - Press F9 to hide field codes and to update the field.

    Another possibility is to tick Confirm conversion at Open in the General tab of Tools | Options...
    Then select the data source for the mail merge again.
    You'll be prompted to select a method. If you choose "MS Excel worksheets via DDE" instead of the default "OLE DB Database Files", number formatting in Excel will be preserved in the merged document. (See <post#=434,784>post 434,784</post: > for a screenshot)

  4. #4
    3 Star Lounger
    Join Date
    Jan 2001
    Posts
    313
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mail merge 0's (Excel/Word 2003)

    Thank you for the suggestions. I will try them. I was hoping that it was just a setting. Someone else in the department has the same version of Office and the 0's are showing up with no problem.

    thanks

  5. #5
    3 Star Lounger
    Join Date
    Jan 2001
    Posts
    313
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mail merge 0's (Excel/Word 2003)

    Thank you - this worked great!

    Another possibility is to tick Confirm conversion at Open in the General tab of Tools | Options...
    Then select the data source for the mail merge again.
    You'll be prompted to select a method. If you choose "MS Excel worksheets via DDE" instead of the default "OLE DB Database Files", number formatting in Excel will be preserved in the merged document. (See post 434,784 for a screenshot)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •