Results 1 to 13 of 13
  1. #1
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Beirut, Lebanon
    Posts
    158
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Icon do not display correctly (WinXP Pro/SP2)

    I am having problems extracting icons from libraries, e.g., if I open a library in Windows Explorer I get a display of files with all icons shown with an icon having a magnifying glass. If I extract an Icon with, say IconEX, I get the correct Icon picture, but when I save the extracted file It opens In Nero Photosnap Viewer with just f frame and only white where the picture should be....ICO is associated the Windows Metaifile and I ran restore with no changes. What I am trying to do, with no success, is to extract icons from a collection and put them in my desktop tray....the only I get is the magnifying glass icon...what I need is a fix so I can create icons from collection on my desk top for further arranging....Any ideas would be appreciated....

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    I'm not exactly sure what you are trying to do....what do you mean by your 'desktop tray' and 'create icons from collection' and 'ICO is associated the Windows Metaifile and I ran restore with no changes'?.....if you are trying to extract an icon from a DLL or similar so that you can assign it to a shortcut then try IconForge......

  3. #3
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Beirut, Lebanon
    Posts
    158
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    I gave IronForge a try...the collection I used was a Library DLL) file and the icons were shown correctly. Saved the icons I wanted which were created in a ICL files (looks like sheet of paper with graphs), but certainly not the icons I extracted from the library file. What I am trying to do is extract the icons from a library file to my desktop and then drag them to the tray at the bottom of the desktop....Any suggestions how to do this in IconForge....?

  4. #4
    Silver Lounger
    Join Date
    Apr 2001
    Location
    New York, New York, USA
    Posts
    2,328
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Icon do not display correctly (WinXP Pro/SP2)

    Also: an icon file (.ico) is 32 x 32 pixels BMP picture, which you can open in any picture editor, as Paint (that comes with Windows). I don't understand, why you use Photosnap Viewer (it was created to view rather huge pictures) to view the icon. If the picture is blank, that means, extraction process failed. Use another extractor program.

    -------------Later addition--------------------

    ICL file is icon library file, not an icon.

    I also do not understand the purpose to put an icon (without a link) into the tray.

  5. #5
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    >>> Saved the icons I wanted which were created in a ICL files (looks like sheet of paper with graphs), but certainly not the icons I extracted from the library file

    What exactly does that mean?
    You saved the icons you wanted, but you didn't save the icons extracted from the library file?
    or
    The icons you created looked like graph-paper, but the icons you extracted did not?


    >>> What I am trying to do is extract the icons from a library file to my desktop and then drag them to the tray at the bottom of the desktop

    So, you want to save an icon to your desktop, yes?
    But then you want to drag it to what? The Taskbar? Your QuickLaunch bar?
    I don't think it is possible to simply place an image on either - it needs to be associated with - for example - a shortcut, and you then drag the shortcut to your QuickLaunch bar.


    >>> Any suggestions how to do this in IconForge....?

    Open IconForge
    Use IconForge to open a file containing the icon you want, and save it somewhere.
    Create a shortcut on your desktop to a program.
    Edit the properties of the shortcut to change the icon to the one you just saved.
    Drag the shortcut from your desktop to the QuickLaunch bar.

  6. #6
    Uranium Lounger
    Join Date
    Mar 2001
    Location
    New Jersey
    Posts
    6,684
    Thanks
    1
    Thanked 11 Times in 11 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    Take a look here and see if any of these utilities help.
    <IMG SRC=http://www.wopr.com/w3tuserpics/DocWatson_sig.gif>

  7. #7
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Beirut, Lebanon
    Posts
    158
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    O.k., tried Icon Sushi and the same problem, e.g., saved an icon to an ICO file but file does does not display proper icon and when I try to put the file on the desktop and I get some sort of universal icon instead display. Anyhow, I have not had this icon problem before and plan to re-install OS in next week or so (largely because of another problem I have... unable to fix problem related to right click on icons)....
    Thanks for all the responses....

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    Could you please try to explain what you are trying to achieve.

    It is unusual to put icon files on the desktop. The usual procedure is to put a shortcut to a program or document on the desktop. This shorrtcut then displays the icon associated with the particular application. You can change the icon displayed by a shortcut by right clicking on it and choosing properties.

    If you just put icon files on the desktop then they will all display the icon for the application associated with .ICO files.

    StuartR

  9. #9
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Beirut, Lebanon
    Posts
    158
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    I'm trying to put a couple icons in the tray so I can click on them to open a dialup and a cable connections...I seem to have lost the ones I had and I can't seem to replace them. I can find the proper icons but can't get them in the tray (or desktop to drag them to the tray)....The problem is that when I right click on the properties for the appropriate icon in network connection I don't find a dialog for changing the icon...don't remember how I did this before (but it wasn't a problem as I remember) but I am having a problem with an "application error" when I right click on desktop/drive, etc. icons...Anyhow, I expect to format/re-install everything shortly, but any advice on the icons for my network connections would be appreciated.....

  10. #10
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    I no longer have a Windows 2000 system at home, but according to this article all you need to do is
    > Create a desktop shortcut for a connection. Right-click its icon and choose Create Shortcut.

    This method works for Windows 2000 and Windows XP.

    StuartR

  11. #11
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Beirut, Lebanon
    Posts
    158
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    That is correct, I can move the current iron to the desktop but once on the desktop a right click of the icon I want to change it doesn't work (application error)...the only suggestion I am getting to fix the application error is re-install windows (which I am reluctant to do as I just did it), but it looks like I'm going to have reformat/re-install in the next week or two....Thanks for the comment...

  12. #12
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    Ah, I'm starting to understand.

    Can you please confirm that this description of your probem is correct:
    Whenever you right click a shortcut to a dialup connection on your desktop you get an application error.

    Because applications can add things to the right click menu, it is possible for this symptom to be caused by all sorts of rogue software. Here are a few questions to help us try to understand the problem better.
    <UL><LI>What is the exact error message that you are getting?
    <LI>Did you install any new software shortly before this behaviour started?
    <LI>Does this happen if you right click other shortcuts on your desktop?
    <LI>Does this happen if you right click files and folders on your desktop that are not shortcuts?
    <LI>Does this happen if you open Windows Explorer and right click shortcuts, files, or folders that aren't on the desktop?[/list]StuartR

  13. #13
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Icon do not display correctly (WinXP Pro/SP2)

    I have just realised that this is lthe same error on the same PC as we are discussing in <post#=515,088>post 515,088</post: >, so I'm going to lock this thread.

    Please continue the discussion there.

    StuartR

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •