Results 1 to 3 of 3
  1. #1
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    PerfectDisk Application Error

    On the 17th I mentioned <!post=in this post,526,776>in this post<!/post> that I had been doing some re-partitioning work with Acronis Disk Director. All that work went well, recent CHKDSK runs read nicely, all is operating successfully as far as I can tell. BUT, starting the next morning, after my usual 2 AM nightly defrag with PerfectDisk, I began to find an error window on my screen in the morning - see attachment from Event Viewer. Since I was one version update behind on PerfectDisk, I updated it and yesterday morning there was no error message on the screen or in Event Viewer. Today the error message is back. The log for PerfectDisk says the defrags were successfully completed and the PD graphic representation of the drives "looks OK" and as I would expect it to look. (BTW, I only defrag the C: and D: partitions which are the Primary partitions on the first two hard drives.)

    Before I write to Raxco to see if they have a lead, can anyone tell me if there's anything in this attachment that will help me solve the problem myself? I've never had to use the Event Viewer and don't know if the category or ID numbers tell me anything or not. Thanks.

    Edited to make the subject more meaningful.

  2. #2
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: PerfectDisk Application Error

    Sorry folks, I moved my own post from XP to Software because I may have already found the problem. Rather than delete the whole thing, I think it might be of some use to those who run PerfectDisk (maybe other defrag'ers as well).

    I had another senior moment when I made that post and said I only defrag my C: and D: partitions. I realized it immediately after posting, so I went back to the PerfectDisk log file and checked the day or two immediately PRECEDING all the re-partitioning work I did. Sure 'nuff, my other partitions HAD been defragging prior to the 17th and stopped doing so after the re-partitioning work I did. I do defrag all partitions on the first two drives except the one where my swap file is.

    It seems to me that PerfectDisk lost its way to all but the C: and D: because those two were NOT involved in the re-partitioning and are the first (primary) on each drive. All my other partitions were re-done and/or moved. I think that PerfectDisk may have lost some binary pointer to the physical locations and breadth of the partitions, so its engine was backfiring on me! By the way, I did change the sizes of the C: and D: partitions, but their starting location at the beginning of the drives did NOT change. I have deleted the scheduled job in PerfectDisk and, after analyzing all the partitions to make sure PD can "find" them, I've created a new job for 2 AM tomorrow. I'll let you know tomorrow so that future Loungers who mess around with partitions AND PerfectDisk can be aware. If this turns out to be true, I plan to write to Raxco to let them know, for I don't see anything related on their FAQs.

    Edited to make the subject more meaningful.

  3. #3
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: PerfectDisk Application Error

    My wild guess evidently was correct. The overnight PerfectDisk defrag new job I created ran without error. I've notified Raxco, not as a complaint, but thinking that they may want to add something to their FAQs about partitioning changes interfering with existing scheduled defrag jobs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •