Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Word/WOPR Weirdness (Office 2003 SP2)

    Yesterday I tried to open a file from Word's File menu and got this:

    "compile error in hidden module: modShadowMacros" message.

    Since I am also having troubles getting Word to close ever since I installed WOPR 2003, I re-installed WOPR and got an error message after the install. The message is:

    [11/7/2005 1:38:33 PM]
    Error=Procedure 'modValidateReferences.Main()' encountered the following critical error: Unable to install/load C:Program FilesWOPR 2003Wopr_lib.dot
    [11/7/2005 1:38:50 PM]
    Error=Procedure 'modValidateReferences.Main()' encountered the following critical error: Unable to install/load C:Program FilesWOPR 2003WorkBar.dot

    So I started from scratch by uninstalling WOPR and restarting Word. Everything worked fine and I could open any existing file from the File menu. I then re-installed WOPR 2003, restarted Word and I once again got the "compile error in hidden module: modShadowMacros" message. I tired this procedure several times with the same result each time.

    I then tried to repair/reinstall Office 2003 after uninstalling WOPR, then reinstalling WOPR. Once again, same result. I tried uninstallng the Vbe6.dll file and reinstalling it from the Office installation CD. Still no go.

    Lastly, I tried a complete uninstall and reinstall of Word, followed by a reinstall of WOPR and the problem remains. I tried once more to uninstall and re-install the Vbe6.dll file. THE DAMN PROBLEM STILL WON'T GO AWAY!!

    Oh yes, now WOPR doesn't work either.


    HELP!!!!

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    <P ID="edit" class=small>(Edited by jscher2000 on 08-Nov-05 12:37. )</P>I just installed WOPR 2003 on Office 2003 Pro SP2. So far, no weirdness. This is not my main computer, so I don't have much here to experiment with.

    Would you mind checking the following?

    Tools > Macro > Security...

    Security Level: (e.g., Very High, High, Medium)

    Trusted Publishers list & checkboxes (e.g., Trust all installed add-ins and templates)

    Prior Trusted Sources (mine lists Pinecliffe International #1, #2, #3)

    What do you see when you run this macro code?

    <code>Sub ListAddins()
    Dim add As Word.AddIn, com As Office.COMAddIn
    With ActiveDocument.Content
    .InsertAfter vbCrLf & "Regular Word Add-ins:"
    For Each add In Word.AddIns
    .InsertAfter vbCrLf & IIf(add.Installed, "[X]", "[ ]") & vbTab & _
    add.Name & vbTab & add.Path
    Next
    .InsertAfter vbCrLf & vbCrLf & "Office COM Add-ins:"
    For Each com In Application.COMAddIns
    .InsertAfter vbCrLf & IIf(com.Connect, "[X]", "[ ]") & vbTab & _
    com.ProgID
    Next
    End With
    End Sub</code>

    Mine is like so:
    <pre>Regular Word Add-ins:
    [X] Wopr_ui.dot C:Program FilesMicrosoft OfficeOFFICE11STARTUP
    [X] FloppyCopy.dot C:Program FilesWOPR 2003
    [X] Wopr_lib.dot C:Program FilesWOPR 2003
    [X] WorkBar.dot C:Program FilesWOPR 2003
    [ ] Date And Time Tools.dot C:Program FilesWOPR 2003
    [ ] Document Notes.dot C:Program FilesWOPR 2003
    [ ] Envr03.dot C:Program FilesWOPR 2003
    [ ] FastFonts.dot C:Program FilesWOPR 2003
    [ ] FileNew Popup.dot C:Program FilesWOPR 2003
    [ ] Formatting Toolbar.dot C:Program FilesWOPR 2003
    [ ] Insert Picture.dot C:Program FilesWOPR 2003
    [X] Lil'WOPRs.dot C:Program FilesWOPR 2003
    [ ] Lookup Zip+4.dot C:Program FilesWOPR 2003
    [ ] Module Tools.dot C:Program FilesWOPR 2003
    [ ] Popup Contacts List.dot C:Program FilesWOPR 2003
    [ ] QuickMarks.dot C:Program FilesWOPR 2003
    [ ] ShowAll.dot C:Program FilesWOPR 2003

    Office COM Add-ins:
    [X] WOPRCommander03.WdConnect
    [X] WOPRImageExtractor03.WdConnect
    [X] WOPRTaskPaneCustomizr03.WdConnect
    [ ] WordEEFonts.Connect</pre>

    Maybe we can find a conflict or discrepancy.

  3. #3
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    Thanks for your post.

    I did check the security settings. They are:

    Security Level: High
    Trusted Publishers List: Trust all add-ins and templates
    Prior Trusted Sources: lists Pinecliffe International, Pinecliffe International #1, #2 and #3.

    I haven't tried to run the macro yet. I've never run Word macros before, so I'm working my way through that....what will this accomplish?

    After reinstalling both Office 2003 and Windows XP, it seems that the WOPR installation fails and I'm wondering if I have a corrupted version of the install file. From the time I first installed it, I had troubles not being able to shut down Word from the file menu or the icons......I've had to go into Task Manager and manually shut Word down. That only happened after installed WOPR, and now the problems only happen after installing WOPR, so I suspect the problem is in WOPR, not Word or Windows.

  4. #4
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    Since my last post, I created and ran the macro. Without WOPR installed it runs fine, but with WOPR installed it will not run.

    I cannot run WOPR Commander to install any modules, either. It says there is a file missing. After multiple tries at installing, I do not believe the WOPR install program is running correctly. I don't know why but it just can't be.

  5. #5
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    One other thing: when you ran the macro without WOPR loaded, did it list anything? In a fresh, clean install of Word, I would suspect not, so if you did find any regular or COM add-ins, we'd want to consider whether those could be conflicting with WOPR.

  6. #6
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    I don't know what to suggest at this point, except to try the WOPR support form and see if that helps.

    Added: You might include the URL of this thread as background when you complete the form: http://www.wopr.com/cgi-bin/w3t/showflat.p...p;Number=533087

  7. #7
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    No, I didn't see any add-ins from WOPR or Wopr Commander. I've already written to WOPR support, but it's only one man, Mike, at this time. It might be awhile. Do you know how I might obtain a clean copy of WOPR to try?

  8. #8
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    Here's an update:

    I tried loading the macros manually from the Tools menu in Word. Now WOPR is loaded and configured. I have no idea why the missing files didn't get installed by the program.

    However, I am back to my original problem: I can't close Word from the file menu or the "x" box. Every time I have to open Task Manager and manually close the rpogram. Any ideas?

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    For a fresh copy of WOPR 2003, you need the CD. (Mine checked for updates after installing and said there weren't any.)

    To exit Word, does the WOPR Commander's bottom option work?

  10. #10
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    Please don't miss the point -- my copy of WOPR 2003 was downloaded when I purchased it. I've since saved it to CD so I don't have a "factory" CD to reload from. I'm thinking perhaps the file was corrupted during the download, and I wanted to get a fresh download.

    I didn't know there was an option in Commander so I will check that out. Thanks!

  11. #11
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    I guess I get the "Duh" Award of the Week! I never used the Exit option in Commander before....didn't even know it was there! Of course, it works perfectly.

  12. #12
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    Sorry, I forgot that Que got cheap and started requiring downloads rather than giving you the CD in the back of the book.

    Glad you found at least one way to close Word. Still, I'm not sure why File>Exit doesn't work...

  13. #13
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    I'm puzzled too....and I still don't understand why the installation program didn't work. The files it said it couldn't find or install were there in the Program folder. Once I got Word to manually add them in, everything was fine. But I still wonder if the problems closing Word aren't related to something in my program copy and all the other weirdness.

    I wrote to Tech Support, but only Mike is left to give it and I still don't know how to download a fresh copy. Any ideas?

  14. #14
    New Lounger
    Join Date
    Nov 2005
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Word/WOPR Weirdness (Office 2003 SP2)

    BTW, I ordered an upgrade from WOPR 2000 to WOPR 2003. I might still have the WOPR 2000 CD around somewhere, but now that things are working pretty much okay, I'm not fixin' what ain't broke!

    I appreciate all your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •