Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Change In FF Behaviour (FF 1.0.7)

    In the thread started by <!profile=Jezza>Jezza<!/profile> I finally joined the Firefox community and have been very pleased with the browser so far. However, one of the "bennies" I initially experienced has suddenly disappeared and I wonder if anyone has any idea why. In <!post=this post,532,849>this post<!/post> of the aforementioned thread I commented that I finally am able to visit links on CNN.com and able to see javascript links that lead to video. Well, yesterday I discovered that those javascript links on CNN.Com no longer work. When I click on one, nothing happens. I've added NO extensions and the only thing I've done is download a few themes to check out the skins. I'm still using the default, but I did try the look of several of the themes. I've just gone through all my FF settings and can't see anything that gives me a clue. Can someone advise, please?

    If you decide to check the CNN site, look for your status bar to tell you that it's a javascript link, particularly the ones that have "Watch" in the page entry.

  2. #2
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    I hope y'all don't mind me posting this followup. Whilst digging around trying to figure out what might be wrong, I was going completely through my settings window and couldn't find anything suspicious. I opened the Javascript Console window, which I admit I know zero about and saw all kinds of "error" messages, so I snapped a couple of screenshots which I've cropped here. Does anything here give someone a clue about what might have happened to my installation of FF?
    Attached Images Attached Images

  3. #3
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Al

    As one FF newbie to another have you tried looking at Tools|Options|...|Web Features and seen if you have Enable Javascipt ticked...and also clicked on Advanced next to this option?
    Jerry

  4. #4
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Yes, thanks, that's the first place I went and I have them ticked. The Advanced window shows the following.
    Attached Images Attached Images

  5. #5
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Windows Media 10 Installed?

    Delay in replying was caused by me getting the update message and upgrading
    Jerry

  6. #6
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Yes, WMP 10 has been installed all along and just a week ago when I installed FF I was able to follow those javascript links.

  7. #7
    Platinum Lounger
    Join Date
    Jan 2001
    Posts
    3,788
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Hi Al

    One guide that may assist is the section on the WMP plugin in the Step-By-Step Guide: Embedded Windows Media in Firefox 1.0.x - MozillaZine Forums. I do not have the ActiveX plugin and can view the CNN videos so that section of the guide should not apply to CNN.

  8. #8
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Thanks, Tony, very informative but not the answer. My setup passes the WMP test immediately and just for assurance I went down through the rest of the article, checking ALL the WMP plugin files against what my FF reports - exact match. So I don't think the problem is WMP.

    I think it must have something to do with executing javascript links because it worked when I first installed FF. I did try re-installing FF early this morning but that didn't help, although I did not un-install first. I'm hoping that someone can decipher those attachments I posted yesterday, for I got another like that this morning after re-installing, rebooting and trying a link on the CNN page.
    Attached Images Attached Images

  9. #9
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts

    Re: Change In FF Behaviour (FF 1.0.7)

    window.open is a method used for "pop-ups" so you could try making a cnn.com exception in the pop-up blocker.

    The "deprecated method" warnings in your other post are due to code in the Lounge. Our pages are not updated to use the latest standards unless the old code actually stops working. <img src=/S/grin.gif border=0 alt=grin width=15 height=15>

  10. #10
    Platinum Lounger
    Join Date
    Jan 2001
    Posts
    3,788
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    CNN video seems to be very temperamental, playing around with various settings I have succeeded in getting it to not work on my browser. <img src=/S/grin.gif border=0 alt=grin width=15 height=15> In my case it was a different problem, I got the pop-up window but the video did not play.

    I have managed to get CNN video to play again by turning off the ad-blocking and pop-up blocking options in my firewall (Norton Internet Security). I have pop-up blocking turned on in Firefox (no allowed sites). I use the AdBlock Plus extension to block ads, but I have to whitelist cnn.com so that it allows ads to be displayed on that site if I want videos to play.

    I have searched through the MozillaZine Forums and quite a few people have problems with video at CNN but there does not appear to be one set solution for everybody. I have seen recommendations to clear the cache & delete CNN cookies, others reported problems with ad-blocking and CNN videos.

  11. #11
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Thanks to you and Jefferson for the comments! In neither FF nor Sygate, I don't have popups blocked, so I didn't think that would be the problem, but...
    <hr>I have seen recommendations to clear the cache & delete CNN cookies<hr>
    I just went in to the FF cookie manager and DELETED several CNN cookies and the <big>video is working again!</big> I don't know that I'll ever understand how CNN can place cookies that cause their own visitors NOT to be able to visit links THEY place on their news site. Well, at least I know what to watch for in the future. Thanks to all for the tips!

  12. #12
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    Just another followup for historical purposes. I give up on CNN but here for your possible interest are some additional facts in case this happens to anyone on some other web pages. Later in the day on my previous post, I was no longer able (AGAIN!) to view video on the CNN site until I deleted all the CNN cookies in Firefox. That behaviour continues up to now. This morning I couldn't view a video, deleted all their cookies, hit refresh on the CNN page and THEN the video played as it should. I just did my morning re-boot of my computer and can no longer view video on CNN. Goodbye CNN ! ! ! (at least as far as internet video is concerned)

    PS As you can imagine, none of this is a "problem" when using Microsoft's Internet Explorer!!!

  13. #13
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Change In FF Behaviour (FF 1.0.7)

    Presumably you have allowed CNN to deposit whatever cookies they want?
    What happens if you reset the permission, and when asked if CNN can place a cookie, select 'For this session only'?
    (Only a wild guess that this may delete the cookie at the end of the session, but allow it to be replaced in the future.)

  14. #14
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Change In FF Behaviour (FF 1.0.7)

    I've not disallowed any cookies, it's true. Since Tony's lead took me to this cookie problem, I've been making a list of what cookies are created when I first visit CNN (after first having deleted all their cookies), what additional cookies show up after I view a javascript link to a video, and what the list of cookies contains AFTER a computer reboot. Trial and error deleting of one or more cookies hasn't let me to a solution. So, I just tried your idea. I deleted all CNN cookies and changed CNN.COM to "allow for session." Lemme see if that helps - and Thanks for the tip!

  15. #15
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Change In FF Behaviour (FF 1.0.7)

    Why allow them in the first place? I know you are a big fan of CNN, but I find it very intrusive when sites insist on putting multiple cookies on your pc just to allow you in.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •