Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts

    NTFS *.pqi Files - Access Denied (WinXP Pro SP2)

    I have installed WinXP Pro on a new PC. 2 x HDDs use NTFS and each contain several logical partitions. I back up my logical partitions weekly with PowerQuest Drive Image 5 (no I am not upgrading) and have been doing this for several years on other PCs running WinXP Home and Win98, both using FAT32.

    My PCs are on a home network and all in the same Workgroup, there is no Domain and I am the sole user/admin on each PC. I am using Simple File Sharing ONLY and I have System Restore turned off.

    When I use PQDI5 in DR-DOS mode to back up the partitions on the new PC using NTFS, the *.pqi backup files are created correctly but I cannot then access them under NTFS from the new PC under Windows - "Access Denied". This applies to Windows Explorer or the PQDI Image Explorer program. PQDI5 fully supports NTFS supposedly. I cannot even copy the files with Explorer - "Access Denied". I have made the drive "Shared" but I still cannot access the *.pqi files from other PCs on the network either. All other regular NTFS files on the new PC are fully accessible by the other PCs - except from Win98 obviously.

    Now, if I add say a txt file in Windows to the *.pqi NTFS folder, then I have no problems in accessing that txt file from any computer in the network, but nothing will access the *.pqi files - "Access Denied".

    As I said, I am the only user/admin for the whole network and I am using Simple File Sharing ONLY so no NTFS sharing/security permissions have been set.

    I have used Google to search for the problem but nothing relevant is turned up.

    The only way I have found to access the NTFS *.pqi backup files is to convert the NTFS partition to FAT32 (done in a couple of minutes with Partition Magic) and then I can access the *.pqi files from ALL PCs.

    The problem would seem to be to do with the fact the *.pqi files are created under DR-DOS. But seeing I am the only user on the PC, why does NTFS deny me access to these files - my files - under Windows and how can I make them accessible under WinXP?

    Thanks
    Rob

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    I may have missed it, but under NTFS you also have permissions for files and folders. Further than that, each item also has an owner. If you right click on a PQI file and choose Sharing and Security, what users and/or groups have permission to access the files?

    This would also explain why you can access them after converting the file system to FAT32, which does not sport advanced security features and Access Control Lists.
    -Mark

  3. #3
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    Thanks for your reply Mark.

    Since I am using Simple File Sharing under NTFS (Explorer, Tools, Folder Options, View, "Use Simple File Sharing" is checked), there is no Sharing and Security available at the file level. I set the whole NTFS partition to "Share" and "Allow Network Users to change my files" but this still did not allow anybody to access the pqi files as I mentioned above. NTFS Files created under WinXP on this partition can always be accessed by any user on the network if I set the Share option on.

    Since the pqi file backup partition is currently under FAT32 so I can access the files, I will create some additional pqi files at the end of today in an NTFS partition and make sure there is not a Sharing and Security option available for the individual files when created under DR-DOS. I am fairly sure I would have noticed this option if it had been available since I did look for any facility like that on the individual files, but I will double check.

    Rob

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    I suspect that since the Powerquest backup is done with DR-DOS that the file ownership or permissions are not being set correctly for XP. Uncheck the Simple File sharing option and then check the ownership and permissions as Mark had indicated.

    Joe
    Joe

  5. #5
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    Having created a new pqi file in DR-DOS on a new NTFS partition, I turned off Simple File Sharing as you suggested Joe and had a look at the file Permissions when back in WinXP. The only username the pqi file had associated with it was "SYSTEM" which allowed all permissions. I suppose this was given from PQ DriveImage running in DR-DOS. When I added "Everyone" to the username list and gave "Everyone" full permissions I could then, at last, access the pqi file under WinXP.

    Is there any easy way around this problem please with PQDI files? I have not used NTFS before and only wish to use Simple File sharing and have zero need for the advanced security features of NTFS.

    If not, then I will create my backup files in a good old FAT32 partition where I can actually access the files easily without having to change individual file permissions first!

    Thanks for your help.
    Rob

  6. #6
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    Most likely you're stuck with the situation since DR-DOS is decidedly not being updated. I would urge you to read what Woody had to say about Simple File Sharing in a previous newsletter. NTFS offers far more than security - disaster recovery among the items - than FAT32 and is probably the best choice for a file system.
    -Mark

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    The way around it is to upgrade you rbackup software. Many in the Lounge recommend Acronis True Image. BTW, I'd not revert to FAT32. NTFS is a much better file system - much more stable and secure.

    Joe
    Joe

  8. #8
    New Lounger
    Join Date
    Jun 2002
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    Thanks for your comments Mark and Joe, I appreciate them. I am and have been very happy with DriveImage 5 because it runs essentially in DOS as opposed to Windows, so it can genuinely back up the whole partition - though I would not upgrade to the later releases under any circumstances. Apart from this one issue, I see no real justification to upgrade, though I take note of your remarks re Acronis and thanks I will have a look at it.. Currently I am simply intending to keep FAT32 just for the partition I use solely to create the pqi backups. All my other partitions, including the off-line backup pqi copies I also keep, will remain with NTFS.

    Rob

  9. #9
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,585
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

    Re: NTFS *.pqi Files - Access Denied (WinXP Pro SP

    Best of luck. Thanks for posting back.

    Joe
    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •