Results 1 to 5 of 5
  1. #1
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    MSConfig.Exe And Boot.Ini (XP Pro SP2)

    This morning I attempted to run MSCONFIG and nothing would happen - no errors or anything but a 1 second flash of hourglass. I beat around with AdAware and Spybot latest and my virus scan had run (clean) overnight. To make a long story shorter, I found that my Boot.Ini file was duplicated in its entirety. Cleaning it up restored the ability to run MSCONFIG and I don't have any idea why! Here's what it looked like:
    <hr>[boot loader]
    ;timeout=3
    default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Micros oft Windows XP Professional" /fastdetect /NoExecute=OptIn
    [boot loader]
    ;timeout=3
    default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Micros oft Windows XP Professional" /fastdetect /NoExecute=OptIn <hr>
    Background: In <!post=this post,538,057>this post<!/post> and one afterward I reported having problems when I tried to switch from the Sygate firewall to the one provided with Trend Micro 2005 where my drive got clobbered and I lost some files, including my Boot.Ini. The sample text above is from the file out of my recent Acronis image backup but I don't have any idea how it got that way and how long it had been in this condition. I think it happened during the restore, for I had run MSCONFIG in order to disable Sygate. Hmmm... The plot thickens in <!post=this thread,538,253>this thread<!/post> where I am still unable to restore individual files from an Acronis backup. The aforementioned posts explain how I got around the problem. Hence my attempt to run MSCONFIG this morning, for I'm still "investigating" why I can't restore selected files and others are quite able to do so. So, that's the start of MY weekend! Hope yours is going well so far.

    Edited to correct my 2nd link. Sorry!

  2. #2
    3 Star Lounger
    Join Date
    Dec 2000
    Location
    La Verne, California, USA
    Posts
    313
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: MSConfig.Exe And Boot.Ini (XP Pro SP2)

    Big Al,

    Is SYSTEM RESTORE running and attempting to put back things it shouldn't be? Just curious.

  3. #3
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: MSConfig.Exe And Boot.Ini (XP Pro SP2)

    No, system restore has long ago been turned off, but thanks for asking. Since I made that post, I've been thinking along those lines although I don't know how or why XP would do it. When I was told by XP during the disk check that there were a bunch of files corrupt and therefore truncated, I first checked the root of the boot drive and there was NO copy of boot.ini. So I went through my restoration hoops with it and the other files. All I can think of is that somehow, on reboot, Windows ALSO tried to re-create a "default" kind of file and the dupe text got added to the one I had dragged in there. I'll probably never know, but maybe having the info here will help someone out sometime.

  4. #4
    Uranium Lounger viking33's Avatar
    Join Date
    Jun 2002
    Location
    Cape Cod, Massachusetts, USA
    Posts
    6,308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: MSConfig.Exe And Boot.Ini (XP Pro SP2)

    Al,
    Did you happen to check the time-date stamp on the boot.ini file to see when it was modified?
    Maybe you could tie that in with install dates of some of the programs in question and if they might have written the dupe?
    Just a thought.
    BOB
    http://lounge.windowssecrets.com/S/flags/USA.gif http://lounge.windowssecrets.com/S/f...sachusetts.gif


    Long ago, there was a time when men cursed and beat on the ground with sticks. It was called witchcraft.
    Today it is called golf!

  5. #5
    Plutonium Lounger
    Join Date
    Oct 2001
    Location
    Lexington, Kentucky, USA
    Posts
    12,107
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: MSConfig.Exe And Boot.Ini (XP Pro SP2)

    Unfortunately, I didn't, Bob. After I restored it, I checked to make sure it was there but didn't make note of the timestamp. And this morning when I discovered the mess, I saved it again with a new name (boot_old.ini) prior to "fixing" it, so I can't audit trail what may have happened.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •