Results 1 to 4 of 4
  1. #1
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Computer takes ages to appear in Workgroup

    I have a wireless router into which one (XP Pro) PC is permanently and ethernetly wired, and a second (XP Home) PC which is connected to the router via a somewhat flaky wireless connection. I have specified fixed IP addresses, default gateways and DNS servers on both boxes, on the wireless-connected PC mainly because this made the recovery from a disconnection much faster than relying on DHCP.

    When I wake up the wireless connection on the second PC, there seems to be a wait of a few minutes before the first PC appears in the workgroup when viewed from the second PC. Usually the first PC is PINGable from the second PC by IP address, but not by name, until everything sorts itself out a few minutes later.

    I suspect this is due to the second-worst piece of Microsoft network code after WINS, namely the browser. There are the usual event log messages about both PCs arguing about which is the master browser, as is typical.

    So my question is: is there any way to make sure that the second PC is aware of the first PC (and I suppose vice versa) at all times (possibly bypassing the browser function), other than by specifying their names and IP addresses in the HOSTS files?

    Thanks!

    John
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  2. #2
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Computer takes ages to appear in Workgroup

    To stop the browser elections you can set
    <code>HKEY_LOCAL_MACHINESYSTEMCurrentControlSetSer vicesBrowserParametersMaintainServerList</code>
    to a value of NO on the XP Home PC. Have a look at this article for information about these parameters.

    This setting may also help with the browsing speed, let us know if it does.

    StuartR

  3. #3
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Computer takes ages to appear in Workgroup

    Thanks, Stuart! Looks as if I should also set IsDomainMaster to Yes on the XP Pro box?

    John
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  4. #4
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: Computer takes ages to appear in Workgroup

    I think that would be appropriate.

    StuartR

    Edited by StuartR to add
    I have never played with this one, but you may also want to adjust the value of HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesl anmanserverparametersAnnounce.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •