Results 1 to 7 of 7
  1. #1
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Forms not showing (XP)

    I have created a front end database which connects to a back end SQL server. The FE has been working fine in development which was created on Wn 2K PC. I have sent the front end out to a tester who is using a Win XP laptop. I have linked the database successfully via ODBC to the back end. I can view the tables and contents, view the FE queries but as soon as I open a form, I can see the subform but the master form is transparent!!! If I attempt to navigate or press the close button an error message appears and closes the whole database. I have checked the references in the VBE and are all there and pointing to the right places.

    Are there any known causes for this behaviour?

    As an aside the laptop I have connected is profile driven, could this be an issue <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>
    Jerry

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 30 Times in 30 Posts

    Re: Forms not showing (XP)

    What happens if you create a simple form (without subform, without code) bound to the same table or query as the problem form? Does it behave the same way?

  3. #3
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Forms not showing (XP)

    I tried that and it worked fine
    Jerry

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 30 Times in 30 Posts

    Re: Forms not showing (XP)

    Perhaps the problem form has become corrupt. Things you can try (assuming that the form still works correctly on your development PC):
    - Install a fresh copy of the frontend on the laptop, to see if that solves the problem, or
    - Remove elements from the problem form one by one, to see if the problem goes away, or
    - Reconstruct the problem form step by step, testing after each addition whether it still works correctly.

  5. #5
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Forms not showing (XP)

    Sounds like good advice......

    Trouble is the problems is 20 miles away so it will be a VNC job <img src=/S/sad.gif border=0 alt=sad width=15 height=15>

    Thanks Hans
    Jerry

  6. #6
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 30 Times in 30 Posts

    Re: Forms not showing (XP)

    The clearings in the forest are far and wide between?

  7. #7
    Platinum Lounger
    Join Date
    Feb 2002
    Location
    A Magic Forest in Deepest, Darkest Kent
    Posts
    5,681
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Forms not showing (XP)

    All solved.....my main form had a piece of code on it that changed the colour of a combo if it had a certain value on the form Change event. For some reason the users laptop did not like this simple piece of code so I removed the functionality (just a bell and whistle so it was not mission critical) <img src=/S/cheers.gif border=0 alt=cheers width=30 height=16>
    Jerry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •