Results 1 to 4 of 4
  1. #1
    4 Star Lounger
    Join Date
    May 2003
    Location
    Austin
    Posts
    401
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Recent connection errors on server2k (sp4)

    We are getting intermittent connectivity errors involving our .NET v1.1 Web app. These started to appear after an SP4 update, so the timing is kind of eerie. Anyway, the errors are randomly generated permissions errors telling the user they don't have access to the page. These aren't authentic permissions errors though because it may allow you to connect to the page after refreshing. Sometimes it takes several retries. As a side note, it also should be stated that we have implemented an integrated authentication piece on our network which allows the user to bypass the proxy server, but that was working fine prior to the SP4 update. I guess my question is...are there any known security issues or connectivity problems that involve the SP4 upgrade?
    <img src=/S/meltdown.gif border=0 alt=meltdown width=15 height=15>

  2. #2
    Uranium Lounger
    Join Date
    Jan 2001
    Location
    Cincinnati, Ohio, USA
    Posts
    7,089
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recent connection errors on server2k (sp4)

    Devil's Advocate here:

    Not being aware of any particular exploits in Windows 2000 other than, say, oh, the WMF vulnerability which affects everything to come out of Redmond in the last ten years, my money is on .NET being flakey. History proves it: Microsoft rarely gets it right before v3.1. Witness Windows for Workgroups, Windows NT 3.51, NT4 SP3, IE... no, IE has never been right. An exception to every rule.

    Perhaps I am overly cynical but it is earned cynicism. I really do believe that what you describe are kinks in the .NET framework that will be ironed out in "the next version", and that there is no easy solution for you on this one. I certainly hope someone proves me wrong!!
    -Mark

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts

    Re: Recent connection errors on server2k (sp4)

    Do you have all the post sp-4 fixes applied? How about .NET fixes? Have you checked you configuration just to make sure that no connection limits were changed?

    Joe
    Joe

  4. #4
    4 Star Lounger
    Join Date
    May 2003
    Location
    Austin
    Posts
    401
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Recent connection errors on server2k (sp4)

    Well, considering it all was working just fine until AROUND the time of the upgrade, I naturally suspect the upgrade. However, it bears mentioning that there may be human error involved as well. This whole thing balances on bi-weekly code pushes with a team of developers on a continuously changing unfrastructure (can we all agree how Novell networks and MS security do not play especially well together?). Also an IT staff (DBAs) that services around 15,000 employees which has had a few reassingments lately. It's a real security stew around here.

    In any case, without .NET this whole thing would have taken many more years in development and millions more in cost. No complaints (well few anyway) on this side about .NET, other than the 1.0 to 1.1 in the middle of the project was a bit quirky...but code base upgrades are always part of the development cycle, as well.
    Thanks for the reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •