Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    330
    Thanks
    10
    Thanked 0 Times in 0 Posts

    What have I done wrong (Access 2003 winxp sp2)

    In the frmChild I have set a spinbox to a field. I have set elsewhere that the child's school grade is a set calculation by age plus the offset value for latestats, repeating etc. My problem is that when I set a value other than 0 in the offset field, the form will not go past that record and jumps back to the first one. I have no idea on this one, so thanks to all for any help
    "Heading for the deep end"

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: What have I done wrong (Access 2003 winxp sp2)

    You requery the form in the On Updated event of the spin button. This causes the record source to be read anew, just as if the form has just been opened, so you end up on the first record. Instead of Me.Requery, use Me.Recalc in the On Updated event. This updates calculated controls such as Grade.

  3. #3
    3 Star Lounger
    Join Date
    Nov 2001
    Location
    Brisbane, Queensland, Australia
    Posts
    330
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Re: What have I done wrong (Access 2003 winxp sp2)

    Thanks for the fix Hans
    "Heading for the deep end"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •