Results 1 to 12 of 12
  1. #1
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    WOPR Macro security settings (Word 2003 SP2)

    Is there a way to drop the Macro security from High down to Medium that lets WOPR start automatically?
    (That is, without having to give permission each time Word starts.)

  2. #2
    Gold Lounger Rebel's Avatar
    Join Date
    Jul 2001
    Location
    Canada
    Posts
    3,024
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: WOPR Macro security settings (Word 2003 SP2)

    Tools>Macro>Security...>Medium ?
    John
    A Child's Mind, Once Stretched by Imagination...
    Never Regains Its Original Dimensions

  3. #3
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    If set to "Medium" I get a "Security Warning" dialog box when Word starts warning me that Wopr_ui.dot contains macros, and has a button for me ot "Enable Macros."

    I don't want ot have to hit this every time Word starts.

  4. #4
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    Try the following:
    - Select Tools | Macro | Security...
    - Activate the Trusted Sources tab.
    - Tick the check box "Trust all installed add-ins and templates".
    - Click OK.

  5. #5
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    In the Trusted Publishers tab, the "Trust all installed add-ins and templates" checkbox is already checked.

    I guess the operative phrase in the "Medium" choice is "You can choose" -- implying a dialog box is inevitable.

  6. #6
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    What folder is Wopr_ui.dot in? If you set "Trust all installed add-ins and templates" then this should get rid of that warning, but only if the template is in your User Templates folder or Workgroup Templates folder. Maybe you could move this template, or change the value of Workgroup Templates to point to this location.

    StuartR

  7. #7
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    C:Program FilesMicosoft OfficeOFFICE11STARTUP

    But Word is Working as Designed -- the point of the "Medium" setting is to have the user give the "yea or nay" on *every* macro.

    (Chalk this up to a former WorPerfect user learning to use Word.)

  8. #8
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    That is a "legacy" folder for installed add-ins. Medium security should prevent unknown macros from running, but installed software should be OK without asking again every time.

    If you move the template from
    <code>C:Program FilesMicosoft OfficeOFFICE11STARTUP</code>
    to
    <code>Cocuments and SettingsUsernameApplication DataMicrosoftWordStartup</code>
    replacing Username with your correct username, then you will not see these prompts any more.

    StuartR

  9. #9
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    Yes, that worked.
    Thanks.

    (If there was a choice of locations given by the WOPR installation, I don't recall., and I haven't gotten far enough along in my sudies to figure this out myself.)

  10. #10
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    But now the WOPR Commander does not work -- could this change be the reason?

    Clicking the WOPR Commander icon in the Windows toolbar gets the usual menu, but the three sections of actual command are grayed out.
    he only active ones are the Load, Uninstall, Add/Remove itesm a the top, and the Exit Microsoft Word at the bottom.
    From About WOPR... through Toggle 'Lil'WOPR Tools' Toolbar is grayed out.

    How do I fix this?

  11. #11
    Plutonium Lounger
    Join Date
    Nov 2001
    Posts
    10,550
    Thanks
    0
    Thanked 7 Times in 7 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    Woops, at a guess they have hard coded the template location into the toolbar or code. I guess you'll have to move the file back.

    StuartR

  12. #12
    Lounger
    Join Date
    Jan 2006
    Posts
    41
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WOPR Macro security settings (Word 2003 SP2)

    As it turns out, I have all the functionality elsewhere, so it doesn't matter, actually.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •