Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    Mar 2004
    Location
    Mechanicsville, Virginia, USA
    Posts
    130
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Lookup is not working (Excel 2003)

    In the attached workbook I have some lookups on the Graph Data page that do not seem to be working. It only appears to be happening with the QTD Averages (starting in cell C37 of the graph data worksheet). The lookup formula works fine for the very first QTD average, but stops after that. What makes it even more perplexing is that all QTD Avgs work in columns B and F of that same sheet. Can someone take a look at this and let me know where I went wrong.

    Thanks!!

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: Lookup is not working (Excel 2003)

    The LOOKUP function only works correctly if the lookup list is sorted in ascending order; this is not the case. You can use VLOOKUP instead. In C37:

    =VLOOKUP(A37,'Prod Data'!$A$2:$L$34,8,FALSE)

    The FALSE argument specifies that you're looking for an exact match. For an exact match, the first column does not need to ordered. (I didn't bother using named ranges, but I hope you get the idea.)

  3. #3
    2 Star Lounger
    Join Date
    Mar 2004
    Location
    Mechanicsville, Virginia, USA
    Posts
    130
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Lookup is not working (Excel 2003)

    Hans,

    That worked beautifully.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •