Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Jan 2001
    Location
    Strasbourg, France
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Missing external USB hard drive (XP Prof SP2)

    I have a Maxtor One Touch 300GB drive attached to my PC, which has been working perfectly for some time, even though it for some reason appeared as a network drive in Explorer rather than a removable drive. Today it disappeared from Explorer, even though it is listed in Device Manager and the partition is detected by both Partition Magic and Acronis Disk Director. It also appears in the list of USB devices.

    Yesterday I tried to repartition the system disk, first with Acronis Disk Director and when that didn't work with Partition Magic. Everything seemed to go well with Partition Magic and before I did this I had backed up the drive to the USB drive, so at that time it was recognised. Could something have gone wrong due to the repartitioning (I increased the size of the C partition at the expense of D)?

    Any help would be greatly appreciated.
    Martin

  2. #2
    Platinum Lounger
    Join Date
    Jan 2001
    Location
    Quedgeley, Gloucester, England
    Posts
    5,333
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Missing external USB hard drive (XP Prof SP2)

    I doubt that my experience matches yours entirely, but my Maxtor OneTouch II 300 GB external hard drive used to "disappear" completely, in the sense that it was invisible following a power on of the drive and PC. Changing from the drive's FireWire Interface A to FireWire Interface B, or to the USB interface, sometimes solved the problem. I now keep it powered on permanently, even when the PC is powered down, and I've had no trouble since then.

    John
    <font face="Script MT Bold"><font color=blue><big><big>John</big></big></font color=blue></font face=script>

    Ita, esto, quidcumque...

  3. #3
    Lounger
    Join Date
    Jan 2001
    Location
    Strasbourg, France
    Posts
    40
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Missing external USB hard drive (XP Prof SP2)

    Thanks for the response, John. I also tried both methods of switching the drive on before booting or switching it on after boot and it makes no difference. Previously both methods worked and now they don't. Very puzzling.

    Martin

  4. #4
    3 Star Lounger
    Join Date
    Jan 2002
    Location
    CT
    Posts
    361
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: Missing external USB hard drive (XP Prof SP2)

    This has worked for me sometimes, but not always.

    First, remove theUSB plug from the computer. Then in CONTROL PANEL, SYSTEM, HARDWARE, DEVICE MANAGER, select the USB Root Hub that the external drive is using. Uninstall that USB root hub and then reboot. During reboot the hub will obviously be rediscovered. Then plug your drive back into the USB port and see if it is seen by Windows Explorer. Make sure the drive is powered first.

    BH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •