Results 1 to 5 of 5
  1. #1
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    ''x' is not a valid name' (XP SR3)

    I'm just experimenting with writing an Update query on one of my databases. When I try to run it, I am told that 'x' is not a valid name (this happens whatever kind of name I give it). 'Make sure that it does not include invalid characters or punctuation and that it is not too long.' Has anyone any idea of what is causing this?

    best wishes and thanks in advance

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: ''x' is not a valid name' (XP SR3)

    I don't think we can help without seeing the SQL you're trying to run.
    Charlotte

  3. #3
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: ''x' is not a valid name' (XP SR3)

    thanks. I'm not directly trying to run SQL at all--but just to open an Update Query. I can't see where there is any code in design view (it's not as if it were like a form, with a properties tab).
    What may be causing the issue is that the source table is linked to an online SQL database (I'm trying to set up something for examination administration that two of us can have access to). I am trying to copy the data from that into a locally stored table so that I have a bit more manoeuvre for editing it locally.

    Philip

  4. #4
    3 Star Lounger
    Join Date
    Jun 2004
    Location
    Oxford, Oxfordshire, United Kingdom
    Posts
    203
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: ''x' is not a valid name' (XP SR3)

    I've sorted the problem--there was an error in the way I was writing the query. Quite why it should tell me that the query was misnamed, rather than something like syntax error, puzzles me. But it's now working, anyway.

  5. #5
    Plutonium Lounger
    Join Date
    Mar 2002
    Posts
    84,353
    Thanks
    0
    Thanked 29 Times in 29 Posts

    Re: ''x' is not a valid name' (XP SR3)

    We can't tell you either without having any relevant information...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •